[PATCH v4 19/35] acpi: Support writing Device Properties objects via _DSD

Bin Meng bmeng.cn at gmail.com
Mon Jul 13 04:58:45 CEST 2020


On Wed, Jul 8, 2020 at 3:12 AM Simon Glass <sjg at chromium.org> wrote:
>
> More complex device properties can be provided to drivers via a
> device-specific data (_DSD) object.
>
> To create this we need to build it up in a separate data structure and
> then generate the ACPI code, due to its recursive nature.
>
> Add an implementation of this.
>
> Signed-off-by: Simon Glass <sjg at chromium.org>
> Reviewed-by: Wolfgang Wallner <wolfgang.wallner at br-automation.com>
> ---
>
> Changes in v4:
> - Drop embedded // comments in file comment
> - Correct return value comment in acpi_dp_add_child()
> - Rename acpi_dp_write_() to acpi_dp_write_internal() and make static
> - Use a #define for the test context size
> - Add a header file for test to allow sharing the context init function
> - Rename and get_length() into a shared test file
> - Add missing arg to comment for acpi_dp_write()
>
> Changes in v3:
> - Allow the name parameter to be NULL
> - Add error checking to acpi_dp_add_integer_array()
> - Fix 'acpi_device.v' typo
> - Drop unused ACPI_CPU_STRING
>
>  include/acpi/acpi_dp.h | 217 +++++++++++++++++++++++
>  include/acpi/acpigen.h |   1 +
>  lib/acpi/Makefile      |   1 +
>  lib/acpi/acpi_dp.c     | 323 ++++++++++++++++++++++++++++++++++
>  test/dm/Makefile       |   1 +
>  test/dm/acpi.h         |  29 ++++
>  test/dm/acpi_dp.c      | 385 +++++++++++++++++++++++++++++++++++++++++
>  test/dm/acpigen.c      |  39 ++---
>  8 files changed, 974 insertions(+), 22 deletions(-)
>  create mode 100644 include/acpi/acpi_dp.h
>  create mode 100644 lib/acpi/acpi_dp.c
>  create mode 100644 test/dm/acpi.h
>  create mode 100644 test/dm/acpi_dp.c
>

Reviewed-by: Bin Meng <bmeng.cn at gmail.com>


More information about the U-Boot mailing list