[PATCH v10 20/21] doc: riscv: Add documentation for Sipeed Maix Bit

Sean Anderson seanga2 at gmail.com
Tue May 5 21:26:10 CEST 2020

On 5/5/20 1:02 PM, Sean Anderson wrote:
> On 5/5/20 5:01 AM, Rick Chen wrote:
>> Hi Sean
>>> This patch adds documentation for the Sipeed Maix bit, and more generally
>>> for the Kendryte K210 processor.
>>> Signed-off-by: Sean Anderson <seanga2 at gmail.com>
>>> ---
>>> Changes in v9:
>>> - Mark dts code block as "none" explicitly
>>> Changes in v7:
>>> - Split off into its own patch
>>> - Fix size of clint
>>>  doc/board/index.rst        |   1 +
>>>  doc/board/sipeed/index.rst |   9 ++
>>>  doc/board/sipeed/maix.rst  | 298 +++++++++++++++++++++++++++++++++++++
>>>  3 files changed, 308 insertions(+)
>>>  create mode 100644 doc/board/sipeed/index.rst
>>>  create mode 100644 doc/board/sipeed/maix.rst
>> The CI verification of v10 still fail, please check:
>> https://travis-ci.org/github/rickchen36/u-boot-riscv/builds/683207657
>> Thanks,
>> Rick
> Hm, that's strange. I didn't see any of these errors when I ran CI.
> Perhaps it is an interaction with one of the other patches merged. Is
> it possible to get the u-boot.map file? The EPC address is present, but
> without the map we can't tell what function caused the error.
> --Sean

Ok, so I did some testing, and I was unable to recreate the successful
test case on my system. For example, I tried to build commit 8d5d3bc,
which built successfully on travis [1], locally. I got the same output
as the failing build on travis locally (which is attached as build.log).
Perhaps it is related to the warning

qemu-system-riscv64: warning: No -bios option specified. Not loading a firmware.

which is present in the failed tests? I would like to bisect this to
locate the problem, but that won't be possible until I can get a clean
build to start from.

[1] https://travis-ci.org/github/Forty-Bot/u-boot/jobs/682461390

-------------- next part --------------
A non-text attachment was scrubbed...
Name: build.log
Type: text/x-log
Size: 416351 bytes
Desc: not available
URL: <https://lists.denx.de/pipermail/u-boot/attachments/20200505/9019ccd7/attachment-0001.bin>

More information about the U-Boot mailing list