[PATCH 5/8] efi_loader: Make the pkcs7 header parsing function an extern
sughosh.ganu at linaro.org
Sun May 10 13:20:12 CEST 2020
On Fri, 8 May 2020 at 06:21, Akashi Takahiro <takahiro.akashi at linaro.org>
> On Thu, May 07, 2020 at 04:48:30PM +0530, Sughosh Ganu wrote:
> > On Thu, 7 May 2020 at 13:04, Akashi Takahiro <takahiro.akashi at linaro.org
> > wrote:
> > > On Thu, Apr 30, 2020 at 11:06:27PM +0530, Sughosh Ganu wrote:
> > > > The pkcs7 header parsing functionality is pretty generic, and can be
> > > > used by other features like capsule authentication. Make the function
> > > > as an extern, also changing it's name to efi_parse_pkcs7_header.
> > >
> > > The patch itself is fine to me, but is "pkcs7 header" a common term?
> > >
> > I haven't come across it in any other code base. I used it since in the
> > concept of a capsule, the signature is prepended to the capsule payload.
> > you can think of a better name, please suggest so. I will change it in
> > next version.
> Simply, efi_parse_pkcs7_signature()?
> In addition, please update the function description, which still
> mentions "variable."
Ok. Will change.
More information about the U-Boot