[PATCH 07/23] Rename CACHE_SUPPORT to CACHE

Simon Glass sjg at chromium.org
Sun Aug 8 20:20:15 CEST 2021


Rename this option so that CONFIG_IS_ENABLED can be used with it.

Oddly there is already an SPL_CACHE option. Drop it in favour of this one.

Drop the special SPL Makefile rule which is now superfluous.

Signed-off-by: Simon Glass <sjg at chromium.org>
---

 common/spl/Kconfig | 8 +-------
 drivers/Makefile   | 1 -
 2 files changed, 1 insertion(+), 8 deletions(-)

diff --git a/common/spl/Kconfig b/common/spl/Kconfig
index 02076171cf1..821d018968f 100644
--- a/common/spl/Kconfig
+++ b/common/spl/Kconfig
@@ -495,7 +495,7 @@ config SPL_FIT_IMAGE_TINY
 	  ensure this information is available to the next image
 	  invoked).
 
-config SPL_CACHE_SUPPORT
+config SPL_CACHE
 	bool "Support CACHE drivers"
 	help
 	  Enable CACHE drivers in SPL. These drivers can keep data so that
@@ -810,12 +810,6 @@ config SPL_UBI
 	  README.ubispl for more info.
 
 if SPL_DM
-config SPL_CACHE
-	depends on CACHE
-	bool "Support cache drivers in SPL"
-	help
-	  Enable support for cache drivers in SPL.
-
 config SPL_DM_SPI
 	bool "Support SPI DM drivers in SPL"
 	help
diff --git a/drivers/Makefile b/drivers/Makefile
index e806482cc8f..a64ce7c2d59 100644
--- a/drivers/Makefile
+++ b/drivers/Makefile
@@ -37,7 +37,6 @@ ifndef CONFIG_TPL_BUILD
 ifdef CONFIG_SPL_BUILD
 
 obj-$(CONFIG_SPL_BOOTCOUNT_LIMIT) += bootcount/
-obj-$(CONFIG_SPL_CACHE_SUPPORT) += cache/
 obj-$(CONFIG_SPL_CPU) += cpu/
 obj-$(CONFIG_SPL_CRYPTO) += crypto/
 obj-$(CONFIG_SPL_MPC8XXX_INIT_DDR_SUPPORT) += ddr/fsl/
-- 
2.32.0.605.g8dce9f2422-goog



More information about the U-Boot mailing list