Xilinx ZynqMP - ZCU102: SPL not able to use MMC/SD card

Michal Simek monstr at monstr.eu
Wed Dec 1 09:48:18 CET 2021

On 12/1/21 09:40, Daniel Cizinsky wrote:
> On Wed, Dec 01, 2021 at 08:36:12AM +0100, Michal Simek wrote:
>> buildroot config is quite different compare to one which is in the tree. I
>> don't think anybody really keeps that configs there up2date. And there is
>> really no reason not to build it in direct way.
>> Just follow documentation present doc/board/xilinx/zynqmp.rst
>> and in your case run
>> export DEVICE_TREE=zynqmp-zcu102-rev1.1
> Thank you, Michal!
> I have already tried that way. But problems with cross compilation were too
> many, that I have simply taken the config out of the native tree you
> described and used it in Buildroot tree. I am not using Buildroot shipped
> defaultconfig at all.

What kind of issues?

> I tried once again the sole u-boot build, but it is failing to link
> tools/dumpimage and I guess it will go ahead failing on and on if I happen
> to fix this one. That's the place I were at about a month ago...

CI look is using toolchain which you can also get through this.
./tools/buildman/buildman --fetch-arch...

I am using Xilinx toolchain from Vivado/Vitis. But other toolchain 
should be fine too.


Michal Simek, Ing. (M.Eng), OpenPGP -> KeyID: FE3D1F91
w: www.monstr.eu p: +42-0-721842854
Maintainer of Linux kernel - Xilinx Microblaze
Maintainer of Linux kernel - Xilinx Zynq ARM and ZynqMP ARM64 SoCs
U-Boot custodian - Xilinx Microblaze/Zynq/ZynqMP/Versal SoCs

More information about the U-Boot mailing list