Xilinx ZynqMP - ZCU102: SPL not able to use MMC/SD card

Daniel Cizinsky listy at gebbeth.cz
Wed Dec 1 09:40:08 CET 2021

On Wed, Dec 01, 2021 at 08:36:12AM +0100, Michal Simek wrote:
> buildroot config is quite different compare to one which is in the tree. I
> don't think anybody really keeps that configs there up2date. And there is
> really no reason not to build it in direct way.
> Just follow documentation present doc/board/xilinx/zynqmp.rst
> and in your case run
> export DEVICE_TREE=zynqmp-zcu102-rev1.1
Thank you, Michal!

I have already tried that way. But problems with cross compilation were too
many, that I have simply taken the config out of the native tree you
described and used it in Buildroot tree. I am not using Buildroot shipped
defaultconfig at all.

I tried once again the sole u-boot build, but it is failing to link
tools/dumpimage and I guess it will go ahead failing on and on if I happen
to fix this one. That's the place I were at about a month ago...

Daniel Cizinsky at various lists

More information about the U-Boot mailing list