[PATCH v2 09/10] bdinfo: Rename function names to be clearer

Simon Glass sjg at chromium.org
Thu Feb 4 02:53:42 CET 2021


From: Bin Meng <bin.meng at windriver.com>

At present we have bdinfo_print_num() to print unsigned long numbers.
We also have print_phys_addr() which accept numbers that might be
64-bit on a 32-bit platform.

Rename these 2 functions to be clearer:

bdinfo_print_num() => bdinfo_print_num_l()
print_phys_addr()  => bdinfo_print_num_ll()

While we are here, make bdinfo_print_num_ll() public so that it can
be used outside cmd/bdinfo.c in the future.

Signed-off-by: Bin Meng <bin.meng at windriver.com>
---

(no changes since v1)

 arch/arm/lib/bdinfo.c     | 16 ++++++------
 arch/m68k/lib/bdinfo.c    |  2 +-
 arch/powerpc/lib/bdinfo.c |  4 +--
 cmd/bdinfo.c              | 52 +++++++++++++++++++--------------------
 include/init.h            |  3 ++-
 5 files changed, 39 insertions(+), 38 deletions(-)

Applied to u-boot-dm, thanks!


More information about the U-Boot mailing list