[PATCH v3 05/19] Kconfig: Rename SPL_MD5_SUPPORT to SPL_MD5
Alexandru Gagniuc
mr.nuke.me at gmail.com
Thu Jul 15 00:05:33 CEST 2021
From: Simon Glass <sjg at chromium.org>
Drop the _SUPPORT suffix so we can use CONFIG_IS_ENABLED() with this
option.
Signed-off-by: Simon Glass <sjg at chromium.org>
Reviewed-by: Alexandru Gagniuc <mr.nuke.me at gmail.com>
Signed-off-by: Alexandru Gagniuc <mr.nuke.me at gmail.com>
---
common/spl/Kconfig | 2 +-
include/image.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/common/spl/Kconfig b/common/spl/Kconfig
index 896526aec6..2df3e5d869 100644
--- a/common/spl/Kconfig
+++ b/common/spl/Kconfig
@@ -417,7 +417,7 @@ config SPL_CRC32
for detected accidental image corruption. For secure applications you
should consider SHA1 or SHA256.
-config SPL_MD5_SUPPORT
+config SPL_MD5
bool "Support MD5"
depends on SPL_FIT
help
diff --git a/include/image.h b/include/image.h
index e2037d3159..124448f9e4 100644
--- a/include/image.h
+++ b/include/image.h
@@ -65,7 +65,7 @@ struct fdt_region;
# ifdef CONFIG_SPL_CRC32
# define IMAGE_ENABLE_CRC32 1
# endif
-# ifdef CONFIG_SPL_MD5_SUPPORT
+# ifdef CONFIG_SPL_MD5
# define IMAGE_ENABLE_MD5 1
# endif
# ifdef CONFIG_SPL_FIT_SHA1
--
2.31.1
More information about the U-Boot
mailing list