[PATCH 0/3] dtoc: Improve support for 'ranges' property

Simon Glass sjg at chromium.org
Thu Jul 29 03:23:08 CEST 2021


An empty ranges property confuses dtoc at present and it dies with an
error. This series fixes this and a few related things.


Simon Glass (3):
  dtoc: Rename is_wider_than() to reduce confusion
  dtoc: Fix widening an int array to an int
  dtoc: Support widening a bool value

 arch/sandbox/dts/sandbox.dtsi        |  2 ++
 test/dm/of_platdata.c                |  7 ++---
 tools/dtoc/fdt.py                    | 40 +++++++++++++++++++---------
 tools/dtoc/test/dtoc_test_simple.dts |  2 ++
 tools/dtoc/test_dtoc.py              |  9 ++++---
 tools/dtoc/test_fdt.py               | 29 +++++++++++++++++---
 6 files changed, 68 insertions(+), 21 deletions(-)

-- 
2.32.0.432.gabb21c7263-goog



More information about the U-Boot mailing list