[PATCH] cmd: mvebu: Rename rx_training to mvebu_comphy_rx_training

Pali Rohár pali at kernel.org
Wed May 5 22:44:49 CEST 2021


On Wednesday 05 May 2021 09:15:10 Stefan Roese wrote:
> Rename the misleading cmd "rx_training" to "mvebu_comphy_rx_training" to
> avoid confusion and mixup with DDR3/4 training. This makes it clear,
> that this command is platform specific and handles the COMPHY RX
> training.
> 
> Also depend this cmd on ARMADA_8K and not TARGET_MVEBU_ARMADA_8K to make
> is available for OcteonTX2 CN913x.
> 
> Signed-off-by: Stefan Roese <sr at denx.de>
> Cc: Pali Rohár <pali at kernel.org>
> Cc: Marek Behun <marek.behun at nic.cz>
> Cc: Kostya Porotchkin <kostap at marvell.com>
> Cc: Nadav Haklai <nadavh at marvell.com>

Acked-by: Pali Rohár <pali at kernel.org>

> ---
>  cmd/mvebu/Kconfig                                 |  9 ++++-----
>  cmd/mvebu/Makefile                                |  2 +-
>  cmd/mvebu/{rx_training.c => comphy_rx_training.c} | 10 +++++-----
>  3 files changed, 10 insertions(+), 11 deletions(-)
>  rename cmd/mvebu/{rx_training.c => comphy_rx_training.c} (74%)
> 
> diff --git a/cmd/mvebu/Kconfig b/cmd/mvebu/Kconfig
> index f0e4f884d703..7c42c75afbe2 100644
> --- a/cmd/mvebu/Kconfig
> +++ b/cmd/mvebu/Kconfig
> @@ -49,11 +49,10 @@ config MVEBU_UBOOT_DFLT_NAME
>  	  This option should contain a default file name to be used with
>  	  MVEBU "bubt" command if the source file name is omitted
>  
> -config CMD_MVEBU_RX_TRAINING
> -	bool "rx_training"
> -	depends on TARGET_MVEBU_ARMADA_8K
> -	default n
> +config CMD_MVEBU_COMPHY_RX_TRAINING
> +	bool "mvebu_comphy_rx_training"
> +	depends on ARMADA_8K
>  	help
> -	  Perform RX training sequence
> +	  Perform COMPHY RX training sequence
>  
>  endmenu
> diff --git a/cmd/mvebu/Makefile b/cmd/mvebu/Makefile
> index 79299b0814f4..ca96ad01d911 100644
> --- a/cmd/mvebu/Makefile
> +++ b/cmd/mvebu/Makefile
> @@ -5,4 +5,4 @@
>  # https://spdx.org/licenses
>  
>  obj-$(CONFIG_CMD_MVEBU_BUBT) += bubt.o
> -obj-$(CONFIG_CMD_MVEBU_RX_TRAINING) += rx_training.o
> +obj-$(CONFIG_CMD_MVEBU_COMPHY_RX_TRAINING) += comphy_rx_training.o
> diff --git a/cmd/mvebu/rx_training.c b/cmd/mvebu/comphy_rx_training.c
> similarity index 74%
> rename from cmd/mvebu/rx_training.c
> rename to cmd/mvebu/comphy_rx_training.c
> index 4bae7653aca3..0798decfae13 100644
> --- a/cmd/mvebu/rx_training.c
> +++ b/cmd/mvebu/comphy_rx_training.c
> @@ -13,8 +13,8 @@
>  #include <dm/device-internal.h>
>  #include <mvebu/comphy.h>
>  
> -int rx_training_cmd(struct cmd_tbl *cmdtp, int flag, int argc,
> -		    char * const argv[])
> +int mvebu_comphy_rx_training_cmd(struct cmd_tbl *cmdtp, int flag, int argc,
> +				 char * const argv[])
>  {
>  	struct udevice *dev;
>  	struct uclass *uc;
> @@ -51,7 +51,7 @@ int rx_training_cmd(struct cmd_tbl *cmdtp, int flag, int argc,
>  }
>  
>  U_BOOT_CMD(
> -	rx_training, 3, 0, rx_training_cmd,
> -	"rx_training <cp id> <comphy id>\n",
> -	"\n\tRun RX training sequence, the user must state CP index (0/1) and comphy ID (0/5)"
> +	mvebu_comphy_rx_training, 3, 0, mvebu_comphy_rx_training_cmd,
> +	"mvebu_comphy_rx_training <cp id> <comphy id>\n",
> +	"\n\tRun COMPHY RX training sequence, the user must state CP index (0/1) and comphy ID (0/5)"
>  );
> -- 
> 2.31.1
> 


More information about the U-Boot mailing list