[RESEND PATCH v1] psci: rename psci_features function

Alex G. mr.nuke.me at gmail.com
Wed May 5 23:51:49 CEST 2021


On 5/5/21 3:54 PM, Igor Opaniuk wrote:
> From: Igor Opaniuk <igor.opaniuk at foundries.io>
> 
> s/psci_features/psci_features_req/g for the case when both
> ARCH_SUPPORT_PSCI=y and ARM_PSCI_FW=y, that leads to these
> compilation issues:
> 
> drivers/firmware/psci.c:69:12: error: conflicting types for 'psci_features'
>     69 | static int psci_features(u32 psci_func_id)
>        |            ^~~~~~~~~~~~~
> In file included from drivers/firmware/psci.c:23:
> ./arch/arm/include/asm/system.h:548:5: note: previous declaration of 'psci_features' was heremailto:igor.opaniuk at foundries.io
>    548 | s32 psci_features(u32 function_id, u32 psci_fid);
>        |     ^~~~~~~~~~~~~
> 
> Signed-off-by: Igor Opaniuk <igor.opaniuk at foundries.io>
> Reported-by: Alexandru Gagniuc <mr.nuke.me at gmail.com>

Tested-by: Alexandru Gagniuc <mr.nuke.me at gmail.com>

> ---
> 
>   drivers/firmware/psci.c | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/firmware/psci.c b/drivers/firmware/psci.c
> index be57552aba..f1841a1835 100644
> --- a/drivers/firmware/psci.c
> +++ b/drivers/firmware/psci.c
> @@ -66,7 +66,7 @@ unsigned long __efi_runtime invoke_psci_fn
>   	return res.a0;
>   }
>   
> -static int psci_features(u32 psci_func_id)
> +static int psci_features_req(u32 psci_func_id)
>   {
>   	return invoke_psci_fn(PSCI_1_0_FN_PSCI_FEATURES,
>   			      psci_func_id, 0, 0);
> @@ -85,7 +85,7 @@req(PSCI_FN_NATIVE(1_1, SYSTEM_RESET2));
>    static bool psci_is_system_reset2_supported(void)
>   	ver = psci_0_2_get_version();
>   
>   	if (PSCI_VERSION_MAJOR(ver) >= 1) {
> -		ret = psci_features(PSCI_FN_NATIVE(1_1, SYSTEM_RESET2));
> +		ret = psci_features_req(PSCI_FN_NATIVE(1_1, SYSTEM_RESET2));

Can you include a verb in the function name? For example 
request_psci_features(), or call_psci_features()

Alex


More information about the U-Boot mailing list