[PATCH u-boot-marvell v3 27/39] tools: kwboot: Explicitly check against size of struct main_hdr_v1

Marek Behún kabel at kernel.org
Fri Sep 24 23:07:04 CEST 2021


From: Marek Behún <marek.behun at nic.cz>

Explicitly check the image size against size of struct main_hdr_v1.
This way the check is more readable, since the `hdrsz` variable
may semantically contain another value.

Signed-off-by: Marek Behún <marek.behun at nic.cz>
---
 tools/kwboot.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tools/kwboot.c b/tools/kwboot.c
index 4fae44c46e..77bf5cb80b 100644
--- a/tools/kwboot.c
+++ b/tools/kwboot.c
@@ -820,14 +820,14 @@ kwboot_img_patch_hdr(void *img, size_t *size)
 	struct main_hdr_v1 *hdr;
 	uint32_t srcaddr;
 	uint8_t csum;
-	size_t hdrsz = sizeof(*hdr);
+	size_t hdrsz;
 	int image_ver;
 	int is_secure;
 
 	rc = -1;
 	hdr = img;
 
-	if (*size < hdrsz) {
+	if (*size < sizeof(struct main_hdr_v1)) {
 		errno = EINVAL;
 		goto out;
 	}
-- 
2.32.0



More information about the U-Boot mailing list