[PATCH v2 00/12] bloblist: Enhancements for standard passage

Simon Glass sjg at chromium.org
Thu Jan 13 03:26:13 CET 2022


This series collects together the prerequisites for standard passage.
The only change is to drop the CONFIG_IF_ENABLED_INT() macro.

Changes in v2:
- Create an accessor for CONFIG_BLOBLIST_ADDR instead of the Kconfig macro

Simon Glass (12):
  stddef: Avoid warning with clang with offsetof()
  fdt: Drop SPL_BUILD macro
  bloblist: Put the magic number first
  bloblist: Rename the SPL tag
  bloblist: Drop unused tags
  bloblist: Use explicit numbering for the tags
  bloblist: Use LOG_CATEGORY to simply logging
  bloblist: Use 'phase' consistently for bloblists
  bloblist: Refactor Kconfig to support alloc or fixed
  bloblist: Add functions to obtain base address and size
  bloblist: doc: Bring in the API documentation
  bloblist: Relicense to allow BSD-3-Clause

 arch/x86/cpu/broadwell/cpu_from_spl.c |   4 +-
 common/Kconfig                        |  95 +++++++++++--
 common/bloblist.c                     | 119 +++++++++++------
 common/board_f.c                      |   2 +-
 common/spl/spl.c                      |   4 +-
 doc/develop/bloblist.rst              |   8 +-
 drivers/serial/serial-uclass.c        |   3 +-
 include/bloblist.h                    | 184 +++++++++++++++++++-------
 include/fdtdec.h                      |   6 -
 include/linux/stddef.h                |   8 +-
 test/bloblist.c                       |  21 ++-
 11 files changed, 333 insertions(+), 121 deletions(-)

-- 
2.34.1.575.g55b058a8bb-goog



More information about the U-Boot mailing list