[PATCH 1/4] gpio: fix incorrect depends on for SPL_GPIO_HOG
Quentin Schulz
foss+uboot at 0leil.net
Tue Jul 12 17:44:19 CEST 2022
From: Quentin Schulz <quentin.schulz at theobroma-systems.com>
Since commit 83061dbd1c89 ("Rename GPIO_SUPPORT to GPIO"),
SPL_GPIO_SUPPORT has been renamed to SPL_GPIO, meaning that SPL_GPIO_HOG
can never be enabled.
Let's fix this by using the proper name for the Kconfig option.
Fixes: 1d99e673c752 ("gpio: Enable hogging support in SPL")
Cc: Quentin Schulz <foss+uboot at 0leil.net>
Signed-off-by: Quentin Schulz <quentin.schulz at theobroma-systems.com>
---
drivers/gpio/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
index d7f37f0471..7b99bd6539 100644
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -70,7 +70,7 @@ config GPIO_HOG
config SPL_GPIO_HOG
bool "Enable GPIO hog support in SPL"
- depends on SPL_GPIO_SUPPORT
+ depends on SPL_GPIO
help
Enable gpio hog support in SPL
The GPIO chip may contain GPIO hog definitions. GPIO hogging
--
2.36.1
More information about the U-Boot
mailing list