[PATCH] board: venice: add spl_board_loader_name

Tim Harvey tharvey at gateworks.com
Tue Mar 8 19:45:39 CET 2022


Implement spl_board_loader_name to provide more meaningful device names
vs MMC1 and MMC2.

Signed-off-by: Tim Harvey <tharvey at gateworks.com>
---
 board/gateworks/venice/spl.c | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

diff --git a/board/gateworks/venice/spl.c b/board/gateworks/venice/spl.c
index 8b301570577c..b56e1b607d58 100644
--- a/board/gateworks/venice/spl.c
+++ b/board/gateworks/venice/spl.c
@@ -301,3 +301,17 @@ int spl_board_boot_device(enum boot_device boot_dev_spl)
 		return BOOT_DEVICE_NONE;
 	}
 }
+
+const char *spl_board_loader_name(u32 boot_device)
+{
+	switch (boot_device) {
+	/* SDHC2 */
+	case BOOT_DEVICE_MMC1:
+		return "eMMC";
+	/* SDHC3 */
+	case BOOT_DEVICE_MMC2:
+		return "SD card";
+	default:
+		return NULL;
+	}
+}
-- 
2.17.1



More information about the U-Boot mailing list