AW: Problem to build u-boot

Sarmad Ahmad sarmad101 at
Wed Mar 16 07:21:40 CET 2022

I used the version 2021 now I used the 2022.01 unfortunately still the same error
followed the instructions on

git clone

cd u-boot

git checkout 2022.01

sudo apt-get install gcc gcc-aarch64-linux-gnu
i also tried this
apt-get install crossbuild-essential-armhf

sudo apt-get install bc bison build-essential coccinelle \
  device-tree-compiler dfu-util efitools flex gdisk liblz4-tool \
  libguestfs-tools libncurses-dev libpython3-dev libsdl2-dev libssl-dev \
  lzma-alone openssl python3 python3-coverage python3-pyelftools \
  python3-pytest python3-sphinxcontrib.apidoc python3-sphinx-rtd-theme swig

export ARCH=arm

export CROSS_COMPILE=/usr/bin/arm-linux-gnueabihf-
also have export CROSS_COMPILE=arm-linux-gnueabihf-
also have export CROSS_COMPILE=gcc-7-arm-linux-gnueabihf-

make xilinx_zynq_virt_defconfig

when i do export -p i see the export in the terminal before i do make


Von: Fabio Estevam <festevam at>
Gesendet: Dienstag, 15. März 2022 21:08
An: Sarmad Ahmad <sarmad101 at>
Cc: u-boot at <u-boot at>
Betreff: Re: Problem to build u-boot

On Tue, Mar 15, 2022 at 11:03 AM Sarmad Ahmad <sarmad101 at> wrote:
> Hi,
> first thank you for the fast answer
> I have tried it but unfortunately still the same error.

Which U-Boot version are you using?

Please try a recent version, such as U-Boot 2022.01, and paste all
your commands.

More information about the U-Boot mailing list