[PATCH 2/2] event: Rename rest of EVENT_SPY to EVENT_SPY_FULL or EVENT_SPY*
Marek Vasut
marek.vasut+renesas at mailbox.org
Tue Sep 5 15:48:08 CEST 2023
Fix up remaining occurances of EVENT_SPY with no suffix.
Fixes: 6c4cad7438 ("event: Rename EVENT_SPY to EVENT_SPY_FULL")
Signed-off-by: Marek Vasut <marek.vasut+renesas at mailbox.org>
---
Cc: Chanho Park <chanho61.park at samsung.com>
Cc: Leo <ycliang at andestech.com>
Cc: Nikita Shubin <n.shubin at yadro.com>
Cc: Padmarao Begari <padmarao.begari at microchip.com>
Cc: Rick Chen <rick at andestech.com>
Cc: Simon Glass <sjg at chromium.org>
Cc: Yu Chien Peter Lin <peterlin at andestech.com>
---
common/Kconfig | 4 ++--
include/event.h | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/common/Kconfig b/common/Kconfig
index d916194b942..bdc02f75620 100644
--- a/common/Kconfig
+++ b/common/Kconfig
@@ -620,7 +620,7 @@ config EVENT_DYNAMIC
bool
help
Enable this to support adding an event spy at runtime, without adding
- it to the EVENT_SPY() linker list. This increases code size slightly
+ it to the EVENT_SPY*() linker list. This increases code size slightly
but provides more flexibility for boards and subsystems that need it.
config EVENT_DEBUG
@@ -648,7 +648,7 @@ config SPL_EVENT_DYNAMIC
depends on SPL_EVENT && EVENT_DYNAMIC
help
Enable this to support adding an event spy at runtime, without adding
- it to the EVENT_SPY() linker list. This increases code size slightly
+ it to the EVENT_SPY*() linker list. This increases code size slightly
but provides more flexibility for boards and subsystems that need it.
endif # EVENT
diff --git a/include/event.h b/include/event.h
index 311df878c4a..5fffde960d0 100644
--- a/include/event.h
+++ b/include/event.h
@@ -282,9 +282,9 @@ static inline const char *event_spy_id(struct evspy_info *spy)
* {
* return sandbox_early_getopt_check();
* }
- * EVENT_SPY(EVT_MISC_INIT_F, sandbox_misc_init_f);
+ * EVENT_SPY_FULL(EVT_MISC_INIT_F, sandbox_misc_init_f);
*
- * where EVENT_SPY uses ll_entry_declare()
+ * where EVENT_SPY_FULL uses ll_entry_declare()
*
* In this case, LTO decides to drop the sandbox_misc_init_f() function
* (which is fine) but then drops the linker-list entry too. This means
--
2.40.1
More information about the U-Boot
mailing list