[PATCH v3 00/38] spl: Preparation for Universal Payload
Tom Rini
trini at konsulko.com
Mon Sep 25 22:36:07 CEST 2023
On Sun, Sep 24, 2023 at 01:24:45PM -0600, Simon Glass wrote:
> This series tidies up SPL a little and adds some core ofnode functions
> needed to support Universal Payload. It also includes a few minor fix-ups
> for sandbox.
>
> For SPL the changes include CONFIG naming, removing various #ifdefs and
> tidying up the FIT code.
>
> One notable piece of the ofnode improvements is support for flattening
> a livetree. This should be useful in future as we move FDT fixups to use
> the ofnode API.
>
> Changes in v3:
> - Mention testing on qemu-ppce500
> - Add new patch to create a proper symbol for enabling the malloc() pool
> - Add new patch to enable CONFIG_SPL_SYS_MALLOC_F where needed
> - Add new patch to nable CONFIG_TPL_SYS_MALLOC_F where needed
> - Add new patch to use SYS_MALLOC_F instead of SYS_MALLOC_F_LEN
> - Add new patch to tidy up uses of CONFIG_SYS_MALLOC_F_LEN
> - Add new patch to clean up SYS_MALLOC_SIMPLE documentation
> - Add new patch to correct help in TPL_DM and VPL_DM
> - Rebase on the new patch
>
> Changes in v2:
> - Rename based on Tom's feedback
> - Improve readability by moving the size part to the header file
> - Explicitly copy two maintainers as it seems only Mario was auto-cc'd
> - Change the approach to use the header file
> - Use the same condition for both pieces to avoid possible problems
> - No changes as it still seems unclear what should be done
>
> Simon Glass (38):
> spl: Use CONFIG_SPL... instead of CONFIG_..._SPL_...
> spl: Rename SYS_SPL_ARGS_ADDR to SPL_PAYLOAD_ARGS_ADDR
> spl: Avoid #ifdef with CONFIG_SPL_SYS_MALLOC
> spl: mx6: powerpc: Drop the condition on timer_init()
> spl: Drop #ifdefs for BOARD_INIT and watchdog
> spl: Avoid #ifdef with CONFIG_SPL_PAYLOAD_ARGS_ADDR
> spl: Drop the switch() statement for OS selection
> spl: Create proper symbols for enabling the malloc() pool
> spl: Enable CONFIG_SPL_SYS_MALLOC_F where needed
> tpl: Enable CONFIG_TPL_SYS_MALLOC_F where needed
> spl: Use SYS_MALLOC_F instead of SYS_MALLOC_F_LEN
> Tidy up uses of CONFIG_SYS_MALLOC_F_LEN
> doc: Clean up SYS_MALLOC_SIMPLE
> dm: core: Correct help in TPL_DM and VPL_DM
> spl: Avoid an #ifdef when printing gd->malloc_ptr
> spl: Remove #ifdefs with BOOTSTAGE
> spl: Rename spl_load_fit_image() to load_simple_fit()
> spl: Move the full FIT code to spl_fit.c
> spl: Use the correct FIT_..._PROP constants
> spl: Move bloblist writing until the image is known
> dm: core: Reverse the argument order in ofnode_copy_props()
> dm: core: Ensure we run flattree tests on ofnode
> dm: core: Tidy up comments in the ofnode tests
> dm: core: Add a function to create an empty tree
> dm: core: Add a way to copy a node
> dm: core: Add a way to delete a node
> dm: core: Add a way to convert a devicetree to a dtb
> dm: core: Support writing a boolean
> dm: core: Support writing a 64-bit value
> dm: core: Add tests for oftree_path()
> sandbox: Move reading the RAM buffer into a better place
> sandbox: Init the EC properly even if no state file is available
> sandbox: Only read the state if we have a state file
> sandbox: Move the bloblist down a little in memory
> bloblist: Support initing from multiple places
> fdt: Allow the devicetree to come from a bloblist
> command: Include a required header in command.h
> pci: serial: Support reading PCI-register size with base
Specific feedback aside, generally this seems fine.
--
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 659 bytes
Desc: not available
URL: <https://lists.denx.de/pipermail/u-boot/attachments/20230925/83e366f3/attachment.sig>
More information about the U-Boot
mailing list