[PATCH v2] rng: Add Turris Mox rWTM RNG driver
Mark Kettenis
mark.kettenis at xs4all.nl
Mon Feb 5 16:21:04 CET 2024
> Date: Mon, 5 Feb 2024 15:54:12 +0100
> From: Marek Behún <kabel at kernel.org>
>
> So you're using A3720 with OpenBSD? Can I ask which A3720 boards do you
> use?
Hi Marek,
I have a Turris Mox.
Some folks run OpenBSD on the ESPRESSObin and GL.iNet Brume as well
(those are A3700 of course).
Cheers,
Mark
> On Mon, 05 Feb 2024 14:46:24 +0100
> Mark Kettenis <mark.kettenis at xs4all.nl> wrote:
>
> > > Date: Mon, 5 Feb 2024 12:40:14 +0100
> > > From: Marek Behún <kabel at kernel.org>
> > >
> > > Hello Max,
> > >
> > > Out of curiousity, what is your use case for having these random
> > > numbers on this platform in U-Boot?
> >
> > It means that U-Boot will implement the EFI RNG protocol. The OpenBSD
> > bootloader will use that to fill an initial pool of random numbers for
> > the kernel. And the Linux kernel EFI stub uses it to do kernel
> > address space randomization.
> >
> > Cheers,
> >
> > Mark
> >
> > > Below are a few more things to change and then you I'll give my
> > > Reviewed-by tag.
> > >
> > > On Sun, 21 Jan 2024 21:17:16 +0100
> > > Max Resch <resch.max at gmail.com> wrote:
> > >
> > > > A RNG driver for Armada 3720 boards running the Turris Mox rWTM firmware
> > > > from CZ.NIC in the secure processor.
> > > >
> > > > Signed-off-by: Max Resch <resch.max at gmail.com>
> > > > ---
> > > >
> > > > Changes in v2:
> > > > - Removed ring buffer implementation
> > > >
> > > > drivers/rng/Kconfig | 8 +++
> > > > drivers/rng/Makefile | 1 +
> > > > drivers/rng/turris_rwtm_rng.c | 122 ++++++++++++++++++++++++++++++++++
> > > > 3 files changed, 131 insertions(+)
> > > > create mode 100644 drivers/rng/turris_rwtm_rng.c
> > > >
> > > > diff --git a/drivers/rng/Kconfig b/drivers/rng/Kconfig
> > > > index a89c899568..cd72852a47 100644
> > > > --- a/drivers/rng/Kconfig
> > > > +++ b/drivers/rng/Kconfig
> > > > @@ -105,4 +105,12 @@ config RNG_JH7110
> > > > help
> > > > Enable True Random Number Generator in StarFive JH7110 SoCs.
> > > >
> > > > +config RNG_TURRIS_RWTM
> > > > + bool "Turris Mox TRNG in Secure Processor"
> > > > + depends on DM_RNG && ARMADA_3700
> > > > + help
> > > > + Use TRNG in Turris Mox Secure Processor Firmware. Can be used
> > > > + on other Armada-3700 devices (like EspressoBin) if Secure
> > > > + Firmware from CZ.NIC is used.
> > > > +
> > > > endif
> > > > diff --git a/drivers/rng/Makefile b/drivers/rng/Makefile
> > > > index 7e64c4cdfc..ecae1a3da3 100644
> > > > --- a/drivers/rng/Makefile
> > > > +++ b/drivers/rng/Makefile
> > > > @@ -17,3 +17,4 @@ obj-$(CONFIG_RNG_SMCCC_TRNG) += smccc_trng.o
> > > > obj-$(CONFIG_RNG_ARM_RNDR) += arm_rndr.o
> > > > obj-$(CONFIG_TPM_RNG) += tpm_rng.o
> > > > obj-$(CONFIG_RNG_JH7110) += jh7110_rng.o
> > > > +obj-$(CONFIG_RNG_TURRIS_RWTM) += turris_rwtm_rng.o
> > > > diff --git a/drivers/rng/turris_rwtm_rng.c b/drivers/rng/turris_rwtm_rng.c
> > > > new file mode 100644
> > > > index 0000000000..143fe0b47f
> > > > --- /dev/null
> > > > +++ b/drivers/rng/turris_rwtm_rng.c
> > > > @@ -0,0 +1,122 @@
> > > > +// SPDX-License-Identifier: GPL-2.0-or-later OR BSD-3-Clause
> > > > +/*
> > > > + * Copyright (c) 2024, Max Resch
> > > > + */
> > > > +
> > > > +#include <dm.h>
> > > > +#include <malloc.h>
> > > > +#include <rng.h>
> > > > +#include <asm/dma-mapping.h>
> > > > +#include <asm/types.h>
> > > > +#include <mach/mbox.h>
> > > > +
> > > > +/* size of entropy buffer */
> > > > +#define RNG_BUFFER_SIZE 128U
> > > > +
> > > > +struct turris_rwtm_rng_priv {
> > > > + phys_addr_t buffer;
> > > > +};
> > > > +
> > > > +static int turris_rwtm_rng_fill_entropy(phys_addr_t entropy, size_t size)
> > > > +{
> > > > + u32 args[3] = { 1, (u32)entropy, size };
> > > > + int ret;
> > > > +
> > > > + /* flush data cache */
> > > > + flush_dcache_range(entropy, entropy + size);
> > > > +
> > > > + /*
> > > > + * get entropy
> > > > + * args[0] = 1 copies BYTES array in args[1] of length args[2]
> > > > + */
> > > > + ret = mbox_do_cmd(MBOX_CMD_GET_RANDOM, args, 3, NULL, 0);
> > > > + if (ret < 0)
> > > > + return ret;
> > > > +
> > > > + /* invalidate data cache */
> > > > + invalidate_dcache_range(entropy, entropy + size);
> > > > +
> > > > + return 0;
> > > > +}
> > > > +
> > > > +static int turris_rwtm_rng_random_read(struct udevice *dev, void *data, size_t count)
> > > > +{
> > > > + phys_addr_t p;
> > > > + size_t size;
> > > > + int ret;
> > > > +
> > > > + p = ((struct turris_rwtm_rng_priv *)dev_get_priv(dev))->buffer;
> > >
> > > Please declare
> > >
> > > struct turris_rwtm_rng_priv *priv = dev_get_priv(dev);
> > > phys_addr_t phys;
> > > size_t size;
> > > int ret;
> > >
> > > and then do
> > >
> > > phys = priv->buffer;
> > >
> > > > + while (count) {
> > > > + size = min_t(size_t, RNG_BUFFER_SIZE, count);
> > > > +
> > > > + ret = turris_rwtm_rng_fill_entropy(p, size);
> > > > +
> > > > + memcpy(data, (void *)p, size);
> > > > + count -= size;
> > > > + data = (u8 *)data + size;
> > > > + }
> > > > +
> > > > + return 0;
> > > > +}
> > > > +
> > > > +static int turris_rwtm_rng_probe(struct udevice *dev)
> > > > +{
> > > > + struct turris_rwtm_rng_priv *priv;
> > >
> > > = dev_get_priv(dev);
> > >
> > > > + u32 args[] = { 0 };
> > > > + int ret;
> > > > +
> > > > + /*
> > > > + * check if the random command is supported
> > > > + * args[0] = 0 would copy 16 DWORDS entropy to out but we ignore them
> > > > + */
> > > > + ret = mbox_do_cmd(MBOX_CMD_GET_RANDOM, args, ARRAY_SIZE(args), NULL, 0);
> > > > +
> > > > + if (ret < 0)
> > > > + return ret;
> > > > +
> > > > + /* entropy buffer */
> > > > + priv = (struct turris_rwtm_rng_priv *)dev_get_priv(dev);
> > > no need here, do it at the beginning
> > >
> > >
> > > > + priv->buffer = 0;
> > > > +
> > > > + /* buffer address need to be aligned */
> > > > + dma_alloc_coherent(RNG_BUFFER_SIZE, (unsigned long *)&priv->buffer);
> > > > + if (!priv->buffer)
> > > > + return -ENOMEM;
> > > > +
> > > > + return 0;
> > > > +}
> > > > +
> > > > +static int turris_rwtm_rng_remove(struct udevice *dev)
> > > > +{
> > > > + phys_addr_t p;
> > > rename this to phys, and please do it as I described above.
> > >
> > > > +
> > > > + p = ((struct turris_rwtm_rng_priv *)dev_get_priv(dev))->buffer;
> > > > + dma_free_coherent((void *)p);
> > > > +
> > > > + return 0;
> > >
> > > Marek
> > >
>
>
More information about the U-Boot
mailing list