[PATCH v2 12/14] spl: Use unified inline functions for spl_load_info
Simon Glass
sjg at chromium.org
Sun Jul 21 17:25:57 CEST 2024
Rather than declaring completely separate functions, put the code for
each case into the same function. This makes it easier to read.
Signed-off-by: Simon Glass <sjg at chromium.org>
Reviewed-by: Sean Anderson <seanga2 at gmail.com>
---
(no changes since v1)
include/spl.h | 18 +++++++-----------
1 file changed, 7 insertions(+), 11 deletions(-)
diff --git a/include/spl.h b/include/spl.h
index 5dfdf778d2d..2f6a3e64c10 100644
--- a/include/spl.h
+++ b/include/spl.h
@@ -306,31 +306,27 @@ struct spl_load_info {
void *buf);
#if IS_ENABLED(CONFIG_SPL_LOAD_BLOCK)
int bl_len;
+#endif
};
static inline int spl_get_bl_len(struct spl_load_info *info)
{
+#if IS_ENABLED(CONFIG_SPL_LOAD_BLOCK)
return info->bl_len;
-}
-
-static inline void spl_set_bl_len(struct spl_load_info *info, int bl_len)
-{
- info->bl_len = bl_len;
-}
#else
-};
-
-static inline int spl_get_bl_len(struct spl_load_info *info)
-{
return 1;
+#endif
}
static inline void spl_set_bl_len(struct spl_load_info *info, int bl_len)
{
+#if IS_ENABLED(CONFIG_SPL_LOAD_BLOCK)
+ info->bl_len = bl_len;
+#else
if (bl_len != 1)
panic("CONFIG_SPL_LOAD_BLOCK not enabled");
-}
#endif
+}
/*
* We need to know the position of U-Boot in memory so we can jump to it. We
--
2.34.1
More information about the U-Boot
mailing list