[PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF
Tom Rini
trini at konsulko.com
Wed Jul 8 03:12:45 CEST 2026
On Tue, Jul 07, 2026 at 08:04:22PM -0400, Raymond Mao wrote:
> Hi Tom,
>
> On Tue, Jul 7, 2026 at 6:48 PM Tom Rini <trini at konsulko.com> wrote:
> >
> > Now that we have made bloblist have distinct "find" and "create"
> > functions, the global data tag "GD_FLG_BLOBLIST_READY" doesn't quite
> > make sense anymore. Rename it to GD_FLG_BLOBLIST_HANDOFF.
> >
> > Suggested-by: Raymond Mao <raymondmaoca at gmail.com>
> > Signed-off-by: Tom Rini <trini at konsulko.com>
> > ---
> > common/bloblist.c | 8 ++++----
> > include/asm-generic/global_data.h | 4 ++--
> > include/bloblist.h | 2 +-
> > 3 files changed, 7 insertions(+), 7 deletions(-)
> >
>
> Sounds good to me.
> Reviewed-by: Raymond Mao <raymondmaoca at gmail.com>
>
> BTW, do we need another flag for the locally allocated/static-assigned bloblist?
Probably not? But it's been a while since I put a lot thought into this
area. I had this sitting around and noticed I hadn't sent it.
--
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: not available
URL: <https://lists.denx.de/pipermail/u-boot/attachments/20260707/97356e97/attachment.sig>
More information about the U-Boot
mailing list