[PATCH v2 01/14] spl: ufs: rename SPL_UFS_SUPPORT config to SPL_UFS

Balaji Selvanathan balaji.selvanathan at oss.qualcomm.com
Mon Jun 15 10:53:44 CEST 2026


Hi Varada,

On 6/11/2026 4:27 PM, Varadarajan Narayanan wrote:
> On Sat, Jun 06, 2026 at 03:48:32PM +0530, Balaji Selvanathan wrote:
>> Rename the Kconfig symbol SPL_UFS_SUPPORT to SPL_UFS to align with
>> the naming convention used by other SPL storage drivers (e.g.,
>> SPL_SATA, SPL_MMC). This shorter name also works cleanly with the
>> $(PHASE_) prefix macro in Makefiles, allowing uniform use of
>> CONFIG_$(PHASE_)UFS across SPL and TPL build rules.
>>
>> Drop the redundant `depends on UFS` from the SPL_UFS entry since it is
>> already implied by the driver selection.
> How?
Since CONFIG_SPL_UFS and CONFIG_UFS are meant to be for SPL and Proper 
respectively, CONFIG_SPL_UFS is not dependent on CONFIG_UFS.
>
>> Signed-off-by: Balaji Selvanathan <balaji.selvanathan at oss.qualcomm.com>
>> ---
>> Changes in v2:
>> - newly added in v2
>> ---
>>   common/spl/Kconfig    | 7 +++----
>>   common/spl/Makefile   | 2 +-
>>   drivers/Makefile      | 2 +-
>>   drivers/scsi/Makefile | 2 +-
>>   drivers/ufs/Kconfig   | 4 ++--
>>   5 files changed, 8 insertions(+), 9 deletions(-)
>>
>> diff --git a/common/spl/Kconfig b/common/spl/Kconfig
>> index 5fa94098e49..10dcb7b2f87 100644
>> --- a/common/spl/Kconfig
>> +++ b/common/spl/Kconfig
>> @@ -1613,9 +1613,8 @@ config SPL_THERMAL
>>   	  automatic power-off when the temperature gets too high or low. Other
>>   	  devices may be discrete but connected on a suitable bus.
>>
>> -config SPL_UFS_SUPPORT
>> +config SPL_UFS
>>   	bool "Support loading from UFS"
>> -	depends on UFS
>>   	select SPL_LOAD_BLOCK
>>   	help
>>   	  Enable support for UFS in SPL. This allows
>> @@ -1624,7 +1623,7 @@ config SPL_UFS_SUPPORT
>>
>>   config SPL_UFS_RAW_U_BOOT_DEVNUM
>>   	int "SCSI device number of the UFS device to load U-Boot from"
>> -	depends on SPL_UFS_SUPPORT
>> +	depends on SPL_UFS
>>   	default 0
>>   	help
>>   	  UFS devices are usually configured with multiple LUNs, which present
>> @@ -1637,7 +1636,7 @@ config SPL_UFS_RAW_U_BOOT_DEVNUM
>>
>>   config SPL_UFS_RAW_U_BOOT_SECTOR
>>   	hex "Address on the UFS to load U-Boot from"
>> -	depends on SPL_UFS_SUPPORT
>> +	depends on SPL_UFS
>>   	default 0x800 if ARCH_ROCKCHIP
>>   	help
>>   	  Address on the block device to load U-Boot from.
>> diff --git a/common/spl/Makefile b/common/spl/Makefile
>> index 9c94e8f143e..9714ada59f4 100644
>> --- a/common/spl/Makefile
>> +++ b/common/spl/Makefile
>> @@ -38,7 +38,7 @@ obj-$(CONFIG_$(PHASE_)DFU) += spl_dfu.o
>>   obj-$(CONFIG_$(PHASE_)SPI_LOAD) += spl_spi.o
>>   obj-$(CONFIG_$(PHASE_)RAM_SUPPORT) += spl_ram.o
>>   obj-$(CONFIG_$(PHASE_)USB_SDP_SUPPORT) += spl_sdp.o
>> -obj-$(CONFIG_$(PHASE_)UFS_SUPPORT) += spl_ufs.o
>> +obj-$(CONFIG_$(PHASE_)UFS) += spl_ufs.o
>>   endif
>>
>>   obj-$(CONFIG_$(PHASE_)UPL) += spl_upl.o
>> diff --git a/drivers/Makefile b/drivers/Makefile
>> index 43d0ba33281..86a54b5f332 100644
>> --- a/drivers/Makefile
>> +++ b/drivers/Makefile
>> @@ -73,7 +73,7 @@ obj-$(CONFIG_SPL_USB_HOST) += usb/host/
>>   obj-$(CONFIG_SPL_SATA) += ata/ scsi/
>>   obj-$(CONFIG_SPL_LEGACY_BLOCK) += block/
>>   obj-$(CONFIG_SPL_THERMAL) += thermal/
>> -obj-$(CONFIG_SPL_UFS_SUPPORT) += scsi/ ufs/
>> +obj-$(CONFIG_SPL_UFS) += scsi/ ufs/
>>
>>   endif
>>   endif
>> diff --git a/drivers/scsi/Makefile b/drivers/scsi/Makefile
>> index c9af60d5d03..6d1f57bf101 100644
>> --- a/drivers/scsi/Makefile
>> +++ b/drivers/scsi/Makefile
>> @@ -16,7 +16,7 @@ ifdef CONFIG_XPL_BUILD
>>   ifdef CONFIG_SPL_SATA
>>   obj-$(CONFIG_SCSI) += scsi.o scsi-uclass.o
>>   endif
>> -ifdef CONFIG_SPL_UFS_SUPPORT
>> +ifdef CONFIG_SPL_UFS
>>   obj-$(CONFIG_SCSI) += scsi.o scsi-uclass.o
>>   endif
>>   endif
>> diff --git a/drivers/ufs/Kconfig b/drivers/ufs/Kconfig
>> index 49472933de3..64172454bc6 100644
>> --- a/drivers/ufs/Kconfig
>> +++ b/drivers/ufs/Kconfig
>> @@ -78,8 +78,8 @@ config UFS_ROCKCHIP
>>   	depends on UFS
>>   	depends on DM_GPIO
>>   	depends on RESET_ROCKCHIP
>> -	depends on SPL_DM_GPIO || !SPL_UFS_SUPPORT
>> -	depends on SPL_RESET_ROCKCHIP || !SPL_UFS_SUPPORT
>> +	depends on SPL_DM_GPIO || !SPL_UFS
>> +	depends on SPL_RESET_ROCKCHIP || !SPL_UFS
>>   	help
>>   	  This selects the Rockchip specific additions to UFSHCD platform driver.
> Additionally defconfig files that might use CONFIG_SPL_UFS_SUPPORT should be
> updated.

Added this in v2: 
https://lore.kernel.org/u-boot/20260615-spl_ufs-v3-0-360bceb29596@oss.qualcomm.com/

Thanks,

Balaji

>
> -Varada


More information about the U-Boot mailing list