[ELDK] ELDK 4.1 genext2fs segmentation fault

Wolfgang Denk wd at denx.de
Tue Feb 5 23:01:15 CET 2008

In message <000001c86807$688278e0$9601a8c0 at PromessInc.local> you wrote:
> Hi,
> I am using ELDK 4.1.
> When I run the following genext2fs command on Fedora 6 it works fine.
> But, when I run it on Fedora 8 I get a segmentation fault.
> Has anyone else had this problem?
> Can you help me?
> [rob at localhost ro-file-on-CF]$ genext2fs -d rootfs -D rootfs_devices.tab -b
> 50000 -r 0 -i 360 rootfs.img
> Segmentation fault
> [rob at localhost ro-file-on-CF]$

I confirm that we can reproduce the problem.  Thanks for the report.

And it even happens with genext2fs 1.4.1 from the latest ELDK 4.2 beta

We're investigating.

Best regards,

Wolfgang Denk

DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
You have the capacity to learn from  mistakes.  You'll  learn  a  lot

More information about the eldk mailing list