[ELDK] ELDK 4.1 genext2fs segmentation fault

Wolfgang Denk wd at denx.de
Thu Feb 7 11:12:40 CET 2008

Dear Robert,

in message <000001c86807$688278e0$9601a8c0 at PromessInc.local> you wrote:
> When I run the following genext2fs command on Fedora 6 it works fine.
> But, when I run it on Fedora 8 I get a segmentation fault.

As it turns out, this is a bug in the Fedora 8 implementation of  the
GLIBC  2.7  sscanf()  function. We will work around this in ELDK 4.2.
The attached RPM file should have the problem fixed - please  try  it

Best regards,

Wolfgang Denk

DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
"He only drinks when he gets depressed." "Why does he get depressed?"
"Sometimes it's because he hasn't had a drink."
                                     - Terry Pratchett, _Men at Arms_

-------------- next part --------------
A non-text attachment was scrubbed...
Name: genext2fs-1.4.1-1.i386.rpm
Type: application/x-rpm
Size: 20114 bytes
Desc: genext2fs-1.4.1-1.i386.rpm
Url : http://lists.denx.de/pipermail/eldk/attachments/20080207/f4179e0d/attachment-0001.bin 

More information about the eldk mailing list