[ELDK] Jumbo Frames, sil24 SATA driver, and kswapd0 page allocation failures

Dave Cogley dcogley at uslinc.com
Thu Aug 13 00:17:30 CEST 2009

What mounting options are you using to mount the drive? If you are not
already doing so try mounting with the option "sync" to force a write


On Wed, 2009-08-12 at 16:06 -0600, Jonathan Haws wrote:
> > What is the size of your Jumbo Frame MTU? I have had problems on the
> > 440EP with an MTU larger than 4080 related to the MAL allocating
> > multiple buffer descriptors. Try shrinking your MTU to below 4K and
> > see if the problem still occurs.
> I have tried shrinking it to 4000 and I still saw the error.  Our
> system needs to use a standard jumbo frame however (9014 byte MTU). 
> Looking through the EMAC code, it appears that the driver writer took
> the time to implement scatter/gather linking of the multiple
> descriptors.
> The thing that concerns me is that if it really was an MTU issue, it
> would occur just by dumping data over the network.  I ran the system
> overnight receiving 36 MBytes/s without a single hiccup.  That tells
> me that the problem is not in the network, but somewhere in how the
> ATA driver is handling memory.
> I may be wrong though (and I am hoping that I am and someone knows the
> answer).
> Thanks,
> Jonathan

More information about the eldk mailing list