[ELDK] RFSB -> make fails

Detlev Zundel dzu at denx.de
Mon Apr 26 16:20:12 CEST 2010

Hi Axel,

> when i try to make an rootfs with rfsb, i ran into the following problems:
> My Host OS: Ubuntu Jaunty 9.04.
> Sources from rfsb are the latest commit from today.
> PATH and CROSS_COMPILE are set correct.

I presume ELDK 4.2, but what CROSS_COMPILE?  If you tell us, we may
reproduce the problem, because currently I have to guess at a lot of

> The Readme says that i can run make without superuser rights. But why do 
> i get a permission denied from cpio then?

I tried touching my screen for a few seconds while concentrating hard,
but it seems we have to debug rather than rely on spntaneous insights :)

> make

First question - what CROSS_COMPILE setting did you use and did you
modify anything after the first menuconfig step?

> Current target list is  /home/ab/src/git/rfsb/build/images/image.ext2 
> /home/ab/src/git/rfsb/build/images/uRamdisk
> Cleaning /home/ab/src/git/rfsb/build
> Populating /home/ab/src/git/rfsb/build with directories
> Using SELF skeleton from 'config/skeleton/self' to populate file system
> 2 blocks
> cpio: cannot remove current 

Ok, this is defintely the first problem.  Checking the Makefile, I
cannot see a direct problem here, so I have to ask you to debug this
step yourself.  The easiest way would be to do a "rm
status/stamp.populate ; make -n"  Then look for the commands being
executed after the "touch status/stamp.rfsb-skel".  Or post the whole
output and let me see what the Makefile tries to do here.

One question comes to mind - did you move the ELDK installation to
another location in the directory hierarchy?

> /home/ab/src/git/rfsb/build/rootfs/etc/init.d: Directory not empty
> cpio: usr/libexec/pt_chown: Cannot open: Permission denied
> cpio: usr/sbin/suexec: Cannot open: Permission denied
> cpio: cannot remove current 

Hmm, this sounds fishy.  If I check, I find that this belongs to the
httpd group.  So let me guess, RFSB works with the default configuration
but has a problem when you add the httpd package?

> /home/ab/src/git/rfsb/build/rootfs/etc/init.d: Directory not empty

What other packages did you select?

> cpio: images/ramdisk_image.gz: Cannot stat: No such file or directory

Did you really select the SELF package from the menu?

> 114310 blocks
> make: *** [status/stamp.eldk-pkgs] Error 2
> any hints?

Lots, how about answers? ;)


Helena ist verhältnismäßig leicht zu besetzen.  Eine Frau, zarteste Jugend
mit sinnlicher Reife verbindend;  äußerst intelligent,  indes von durchaus
weiblicher Denkart; phlegmatisch, aber sensibel; unübertrefflich schön und
dabei von sehr persönlichem Charme - mehr wird da nicht verlangt.
                                               -- Peter Hacks
DENX Software Engineering GmbH,      MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich,  Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-40 Fax: (+49)-8142-66989-80 Email: dzu at denx.de

More information about the eldk mailing list