[ELDK] RFSB -> make fails

Stefano Babic sbabic at denx.de
Mon Apr 26 16:30:43 CEST 2010

Axel Beierlein wrote:
> Hello,
> when i try to make an rootfs with rfsb, i ran into the following problems:
> My Host OS: Ubuntu Jaunty 9.04.

It works well on Ubuntu.

> Sources from rfsb are the latest commit from today.
> PATH and CROSS_COMPILE are set correct.
> The Readme says that i can run make without superuser rights.

That is correct. I run it always as normal user.

> make
> Current target list is  /home/ab/src/git/rfsb/build/images/image.ext2 
> /home/ab/src/git/rfsb/build/images/uRamdisk
> Cleaning /home/ab/src/git/rfsb/build
> Populating /home/ab/src/git/rfsb/build with directories
> Using SELF skeleton from 'config/skeleton/self' to populate file system
> 2 blocks
> cpio: cannot remove current 
> /home/ab/src/git/rfsb/build/rootfs/etc/init.d: Directory not empty
> cpio: usr/libexec/pt_chown: Cannot open: Permission denied
> cpio: usr/sbin/suexec: Cannot open: Permission denied
> cpio: cannot remove current 

rfs reads file from a current NFS server, or better, where you have
installed ELDK. This means you need permissions to read all files you
need to install.
Try to check the pemission for
$ELDK_root/<your_arch>/usr/libexec/pt_chown. As default, these are set as

-rws------  1 root    root    14873 2008-11-24 18:59 pt_chown

And only root can read the file. Try to add read permission for this
file with "chmod o+r pt_chown".

> /home/ab/src/git/rfsb/build/rootfs/etc/init.d: Directory not empty
> cpio: images/ramdisk_image.gz: Cannot stat: No such file or directory

This means only that the file is not installed or was removed on your
system. You should find it under $ELDK_root/<your_arch>/images.

Best regards,
Stefano Babic

DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: +49-8142-66989-0 Fax: +49-8142-66989-80  Email: office at denx.de

More information about the eldk mailing list