[ELDK] Using FTDI USB serial converter with ELDK

Alberto Caballero alberto.kavan at gmail.com
Wed Sep 29 09:58:46 CEST 2010

Hi Detlev,

Many thanks for your help. I tried the second option you told me. At my
current installation I went to /opt/embedded/linux_2_6 and run "make
menuconfig" to configure the kernel. I could not find any option to
configure the DEVTMPFS device. I checked many menu items but it was useless.

This installation was performed using the Embedded Planet BSP provided CD.

Following your suggestion I downloaded ELDK 4.2 from the ELDK FTP server and
successfully installed it. But now I do not know how should I have to
configure the kernel for the ELDK 4.2. I checked the online documentation
for the ELDK at denx.de web page, but I didn't found anything related to
kernel configuration. At installed folder, I have a ppc_4xx folder which
contains some folder that appears to belong to a Linux distribution.

Now I have two questions:

1) Is it possible to configure this kernel option from the provided BSP (I
think i have a 2.6 kernel version)?

2) Is it only ELDK 4.2 a set of tools for target compilation? How can I use
it to configure and build a valid kernel image suitable for my target board?
I tried to search for this at online documentation unsuccessfully.



2010/9/28 Detlev Zundel <dzu at denx.de>

> Hi Alberto,
> > I am trying to connect a cable that includes a FTDI device into my
> EP440xS
> > board. Following the comments found at some forums and web pages, I
> > configured the kernel so now I have USB serial converter support (not
> > compiled as a module), generic USB serial converter support and FTDI
> > support. After that, I downloaded my new kernel image into the board,
> > start-up the system, check that the USB subsystem was initializating and
> > then plug my cable into the system. After issuing a "dmesg" command, I
> found
> > out that the device was recognized, but no /dev/ttyUSB0 device was
> created.
> This is expected unless you provide means by which such a device file
> can be created.
> The first option would be to use something like udev.  You need to
> explicitely enable udev in ELDK 4.2 by either running 'start_udev' as
> superuser manually or by enabling the call to it in /etc/rc/sysinit in
> line 323.
> For embedded systems, I would much rather look at option 2, namely
> enabling the devtmpfs filesystem in the linux kernel.  This is the
> config option:
> drivers/base/Kconfig:19
>  "Device Drivers"
>    --->  "Generic Driver Options"
> config DEVTMPFS
>        bool "Maintain a devtmpfs filesystem to mount at /dev"
>        depends on HOTPLUG
>        help
>          This creates a tmpfs/ramfs filesystem instance early at bootup.
>          In this filesystem, the kernel driver core maintains device
>          nodes with their default names and permissions for all
>          registered devices with an assigned major/minor number.
>          Userspace can modify the filesystem content as needed, add
>          symlinks, and apply needed permissions.
>          It provides a fully functional /dev directory, where usually
>          udev runs on top, managing permissions and adding meaningful
>          symlinks.
>          In very limited environments, it may provide a sufficient
>          functional /dev without any further help. It also allows simple
>          rescue systems, and reliably handles dynamic major/minor numbers.
>          Notice: if CONFIG_TMPFS isn't enabled, the simpler ramfs
>          file system will be used instead.
> Also be sure to enable this option:
> drivers/base/Kconfig:39
>  "Device Drivers"
>    --->  "Generic Driver Options"
>        bool "Automount devtmpfs at /dev, after the kernel mounted the
> rootfs"
>        depends on DEVTMPFS
>        help
>          This will instruct the kernel to automatically mount the
>          devtmpfs filesystem at /dev, directly after the kernel has
>          mounted the root filesystem. The behavior can be overridden
>          with the commandline parameter: devtmpfs.mount=0|1.
>          This option does not affect initramfs based booting, here
>          the devtmpfs filesystem always needs to be mounted manually
>          after the roots is mounted.
>          With this option enabled, it allows to bring up a system in
>          rescue mode with init=/bin/sh, even when the /dev directory
>          on the rootfs is completely empty.
> Then the device should show up after plugging it in.
> Cheers
>  Detlev
> --
> But solicitors and stockbrokers and bookmakers often lead comfortable and
> happy lives,  and it is very difficult to see how the world is richer for
> their existence.                                  -- G. H. Hardy
> --
> DENX Software Engineering GmbH,      MD: Wolfgang Denk & Detlev Zundel
> HRB 165235 Munich,  Office: Kirchenstr.5, D-82194 Groebenzell, Germany
> Phone: (+49)-8142-66989-40 Fax: (+49)-8142-66989-80 Email: dzu at denx.de

More information about the eldk mailing list