[ELDK] Binutils error - Building a 3.x kernel with ELDK 5.1

Wolfgang Denk wd at denx.de
Sat Mar 17 20:32:23 CET 2012

Dear Fernando,

In message <7938584634fercar at alumni.uv.es> you wrote:
> I've successfully built a 2.6 kernel using ELDK 4.2 for a PowerPC 440 in
> Xilinx ML507 board.
> Now I'm tryind to built a 3.x kernel using ELDK 5.1 for the same device,
> but when I do:
> "make ARCH=powerpc simpleImage.initrd.virtex440-ml507"
> I obtain this error:
> *** 3.0 kernels no longer build correctly with old versions of binutils.
> *** Please upgrade your binutils to 2.12.1 or newer
> make: *** [checkbin] Error 1
> I've cheked my binutils version and it's 2.21
> Can ELDK 5.1 build 3.x kernels?

Yes, we use it all the time for 3.x kernels (actually it's been some
time since I tried it using for an older kernel version).

Are you sure you set up the build environment correctly?  Do you use
eldk-switch or environment-setup-ppc440e-linux to do so?

Which version of "make" is installed on your system (and which distro
/ version are you running) ?

I tried the build in a Fedora 16 environment, and it just worked fine:

  CALL    arch/powerpc/kernel/systbl_chk.sh
  CHK     kernel/config_data.h
  DTC     arch/powerpc/boot/virtex440-ml507.dtb
DTC: dts->dtb  on file "arch/powerpc/boot/dts/virtex440-ml507.dts"
  WRAP    arch/powerpc/boot/simpleImage.initrd.virtex440-ml507
rm arch/powerpc/boot/virtex440-ml507.dtb
-> ls -lh arch/powerpc/boot/simpleImage.initrd.virtex440-ml507
-rwxrwxr-x 1 wd wd 3.6M Mar 17 20:31 arch/powerpc/boot/simpleImage.initrd.virtex440-ml507

Best regards,

Wolfgang Denk

DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
"'Tis true, 'tis pity, and pity 'tis 'tis true."
    - Poloniouius, in Willie the Shake's _Hamlet, Prince of Darkness_

More information about the eldk mailing list