[ELDK] X11 target image - missing libs

Stefano Babic sbabic at denx.de
Wed Mar 6 16:45:33 CET 2013

On 28/02/2013 15:31, Nige Dick wrote:
> Hi


> My own embedded system, based on a PXA166, includes a touchscreen
> QVGA LCD on which I need to have X11 window environment running for
> my end application.
> Using the install scripts as per the ELDK 5.3 Documentation, I've 
> downloaded ELDK 5.3 with an armv5te target architecture and X11
> target configuration. Sorry, I'm a bit of newbie with X11 :-(
> When trying to get  the X11 display up and running, I just get a
> blank screen.

In most cases this a symptom of a misconfiguration in xorg.conf.

> I already have the correct Linux LCD config/initialisation as the LCD
> displays the Linux bootlog ok via the framebuffer device: /dev/fb0.
> From the X11 log file and linux boot info I can see that 'libextmod'
> and 'libdbe' modules are not being loaded. Also the font paths do not
> seem to be present/detected in the build (I'm thinking this might be
> why the display remains blank).

This is independent - which image have you tested ? Have you tried sato
and sato-sdk ?

> These library extensions should be in
> /usr/lib/xorg/modules/extensions/
> but this directory and files don't
> exist. Am I missing a crucial step in order to enable these libraries
> / fonts to be built and linked at ELDK compile time? Are these X11
> extensions really needed for bringing up an X11 display (libdbe -
> double buffering support, libextmod - server extensions) ??
> My X11 setup/config is wrong somewhere....just trying to figure out
> where!!

In most cases, there is no need of xorg.conf at all - have you tried to
remove it ?

Which image have you installed (sato, sato-sdk) ?

Best regards,
Stefano Babic

DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: +49-8142-66989-53 Fax: +49-8142-66989-80 Email: sbabic at denx.de

More information about the eldk mailing list