[ELDK] X11 target image - missing libs

Nige Dick nigedick at yahoo.com
Thu Mar 7 20:53:09 CET 2013

Hi Stefano

Thanks for getting back to me.

The original log supplied was from the ELDK5.3  X11 image. 
I tried removing xorg.conf and got the same end result with this x11 image.
I also tried the sato and sato-dev ELDK images and got the same blank screen. Both images seem to extract the filesystem ok (I can send the log if you need to see it)

Bottom line, I think you are right - its all pointing to some sort of configuration problem.

Do you have an example ELDK filesystem 'X11.log' file of a correctly booting x11 or sato / sato-dev filesystem you can send me? 
This would help me locate what is wrong :-)



 From: Stefano Babic <sbabic at denx.de>
To: Nige Dick <nigedick at yahoo.com> 
Cc: "eldk at lists.denx.de" <eldk at lists.denx.de> 
Sent: Wednesday, 6 March 2013, 15:45
Subject: Re: [ELDK] X11 target image - missing libs
On 28/02/2013 15:31, Nige Dick wrote:
> Hi


> My own embedded system, based on a PXA166, includes a touchscreen
> QVGA LCD on which I need to have X11 window environment running for
> my end application.
> Using the install scripts as per the ELDK 5.3 Documentation, I've 
> downloaded ELDK 5.3 with an armv5te target architecture and X11
> target configuration. Sorry, I'm a bit of newbie with X11 :-(
> When trying to get  the
 X11 display up and running, I just get a
> blank screen.

In most cases this a symptom of a misconfiguration in xorg.conf.

> I already have the correct Linux LCD config/initialisation as the LCD
> displays the Linux bootlog ok via the framebuffer device: /dev/fb0.

More information about the eldk mailing list