[ELDK] U-Boot version required to boot kernel 3.10 on PowerPC

Peter Oruba peter.oruba at gmail.com
Wed Jun 25 15:59:44 CEST 2014

Am 25.06.2014 um 12:50 schrieb Detlev Zundel <dzu at denx.de>:

> Hi Peter,
> [...]
>> I have 
> Now that's interesting.  I cannot remember running a 5200 kernel at an
> offset different than 0xc000.0000 and as far as I can see this is also
> the default for mpc5200_config.  Can you try with this setting?

Sure. The result is

INFO: Uncompressed kernel (size 0x576ac0) overlaps the address of the wrapper(0x400000)
INFO: Fixing the link_address of wrapper to (0x600000)
Image Name:   Linux-3.10.42
Created:      Wed Jun 25 15:45:54 2014
Image Type:   PowerPC Linux Kernel Image (gzip compressed)
Data Size:    2863198 Bytes = 2796.09 kB = 2.73 MB
Load Address: 00000000
Entry Point:  00000000

I load that kernel via TFTP to address 0x600000 (is that ok or is it supposed not to overlap with the wrapper?)
Loading DTB to 0x580000 (slightly higher than Load Address + Kernel size)

Still no output n the console, but I am able to read the kernel message buffer which contains two interesting fragments:

"t device tree!“ 
which is from drivers/of/fdt.c:
		if (tag != OF_DT_BEGIN_NODE) {
                        pr_err("Invalid tag %x in flat device tree!\n", tag);
                        return -EINVAL;


"el BUG at arch/powerpc/mm/ppc_mmu_32.c:281!"
which is

void setup_initial_memory_limit(phys_addr_t first_memblock_base,
                                phys_addr_t first_memblock_size)
        /* We don't currently support the first MEMBLOCK not mapping 0                                                                   
         * physical on those processors                                                                                                  
        BUG_ON(first_memblock_base != 0);


Does this come from a potential kernel/DTB collision? Doing „imi 0x600000“ says everything is OK, so the uImage survives the crash and the reboot.

However, I tried loading the DTB to a very high address like 0xa00000, but then I am getting the same error (no console output) again.
Doing imi on 0x600000 _after_ rebooting this stuck system with high DTB load address says "Bad CRC"

I hope my description is not too confusing.


>> and
>> c258dc9c b __log_buf
>> so I did 'md 0x58dc9c 512‘
> With the special input parameters, this seems correct, yes.
> Best wishes
>  Detlev
> -- 
> Narren sind alle, die es scheinen, und die Haelfte derer, die es nicht
> scheinen ..  Jedoch ist der groesste Narr, wer es nicht zu sein glaubt
> und alle andern dafuer erklaert.
>                                    --- Baltasar Gracian
> --
> DENX Software Engineering GmbH,      MD: Wolfgang Denk & Detlev Zundel
> HRB 165235 Munich,  Office: Kirchenstr.5, D-82194 Groebenzell, Germany
> Phone: (+49)-8142-66989-40 Fax: (+49)-8142-66989-80 Email: dzu at denx.de

More information about the eldk mailing list