[U-Boot-Users] Uncompressing kernel ..... OK (Hangs here)

Scott McNutt ScottM at Orbacom.com
Wed Sep 10 20:48:43 CEST 2003

> I have tried both settings of clocks_in_mhz and have made sure
> that I copied u-boot.h from uboot to ppcboot.h in Linux.

If you're really using a Lynx KDI, this is not necessary. The KDI
should be self-contained.

> I have made sure that IMAP_ADDR is correct but I still get the same
> thing, just hangs after uncompression. I am totally stumped.

This is really, really, important ... double check this. The default Bluecat
hardcodes the IMMR ... it doesn't look for the u-boot parameters ... it just
creates its own bd info struct. So if u-boot and Bluecat are not in sync,
the behavior you describe is just what I would expect.

> vco         = 266.666 MHz
> sccfreq     = 66.666 MHz
> brgfreq     = 66.666 MHz
> intfreq     = 199.999 MHz
> cpmfreq     = 133.333 MHz
> busfreq     = 66.666 MHz
> baudrate    = 115200 bps

This is another area to check. The default Bluecat BSP for VADS has
many of these hardcoded. Although u-boot is smart in this area, Bluecat
is (unfortunately) is not. The Bluecat code may not be setting up the
uart BRG incorrectly -- check any code you borrowed from the VADS


More information about the U-Boot mailing list