[U-Boot-Users] Uncompressing kernel ..... OK (Hangs here)

tn tnghiem at oerlikon.ca
Thu Sep 11 15:40:07 CEST 2003

Hi James,

Another thing you can do is go to u-boot/common/cmd_bootm.c in the function
do_bootm_linux(..), at the end of it :

      (*kernel) (kbd, initrd_start, initrd_end, cmd_start, cmd_end);

change it to

      (*kernel) (gd->bd, initrd_start, initrd_end, cmd_start, cmd_end);  //
kbd change to gd->bd

It should works.

I hope this help.


----- Original Message -----
From: "Yuli Barcohen" <yuli at arabellasw.com>
To: "James Bates" <jbates at paradise.co.uk>
Cc: <u-boot-users at lists.sourceforge.net>
Sent: Wednesday, September 10, 2003 2:19 PM
Subject: Re:[U-Boot-Users] Uncompressing kernel ..... OK (Hangs here)

> >>>>> James Bates writes:
>     James> Hi All,
>     James> I have now managed to get the image to be read in and kernel
>     James> image uncompressed etc. I am getting the problem where it
>     James> hangs after Uncompression though. My previous issue with Bad
>     James> Magic Number errors was due to the compilation of the mkimage
>     James> tool. It was producing images with the wrong endianness in
>     James> the header. Not sure if this may still be my problem tho :)
>     James> I have tried both settings of clocks_in_mhz and have made
>     James> sure that I copied u-boot.h from uboot to ppcboot.h in
>     James> Linux. I have made sure that IMAP_ADDR is correct but I still
>     James> get the same thing, just hangs after uncompression. I am
>     James> totally stumped.
>     James> My board is an adaptation of the MPC8260ADS. I am using
>     James> BlueCat 4.0 and u-boot 4.8 (tried 4.0 and 4.7) etc and have
>     James> tried booting both the uImage and kdi files (after turning
>     James> them into u-boot images with mkimgage).
>     James> Here is a print out with extra debug info when trying a kdi
>     James> image called Q319.img:
> [...kdi staff deleted...]
>     James> Another example which does not use a kdi image but simply
>     James> takes a mkimaged zipped vmlinux file as follows.
> You don't show the mkimage command but if you use gzipped vmlinux
> (i.e. ELF format) file it's exactly the problem. You have to convert ELF
> to raw binary using something like
>     powerpc-linux-objcopy -O binary vmlinux vmlinux.bin
> Then you gzip vmlinux.bin and use it as input to mkimage, just as it's
> explained in the README.
> [...Debug print deleted...]
>     James> Any ideas anyone? You help is much appreciated.
> BTW, note that flash size looks incorrect. Also make sure that 66MHz is
> 66.666 as it appears in your log and not 66.000. It's not connected to
> the boot problem but may cause different problems.
> --
> ========================================================================
>  Yuli Barcohen       | Phone +972-9-765-1788 |  Software Project Leader
>  yuli at arabellasw.com | Fax   +972-9-765-7494 | Arabella Software, Israel
> ========================================================================
> -------------------------------------------------------
> This sf.net email is sponsored by:ThinkGeek
> Welcome to geek heaven.
> http://thinkgeek.com/sf
> _______________________________________________
> U-Boot-Users mailing list
> U-Boot-Users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/u-boot-users

More information about the U-Boot mailing list