[U-Boot-Users] Need help booting linux on IBM 405EP eval board

Jeff Tucker jeff at jltnet.com
Fri Apr 2 03:02:38 CEST 2004

Hi, guys.

I'm having a hard time getting U-Boot to boot Linux on an IBM 405EP 
evaluation board. Here's what I've tried:

First, I think my kernels are fine. I can compile 2.4.18 from an older 
version of the ELDK or I can compile 2.4.24 from the latest released ELDK. 
I'm using ELDK tools for all of my builds. Using the IBM bootloader that 
comes on the board and the "treeboot" image file format, I can get the IBM 
board to tftp my kernel over the lan and run it. So, I think the kernel is 
working fine.

I also don't have any problem running U-Boot. I compiled 1.0.2 and 
installed it on the board. U-Boot runs fine and I can make it tftp a file 
over the network as well. Using iminfo, I can see that it read what I 
expect. However, no matter what I try, I can't get the kernel to actually 

In the older kernel, I'm using a "make pImage" and in the newer kernel I do 
"make uImage". I've also tried running the mkimage tool manually with 
various options to see if I could get a kernel to boot. iminfo says the 
kernel is fine and I get to the "Uncompressing Linux Kernel ... OK" stage 
but it stops there.

I've noticed that the mkimage script is being called to set a start point 
and relocation point both of 0. Does that work on these boards? One person 
posted in the mailing list that you couldn't boot a kernel at 0. I've tried 
changing that to 400000 and it didn't help, though.

Another question I have is that I see 400000 embedded in at least one of 
the kernel build scripts. Is that a special number? Also, the kernel 
itself, by default, seems to build with a start point of 0xc0000000. On my 
system, that's not even RAM. But the kernels I built without changing that 
number boot fine with the IBM bootloader, so maybe it's not actually used 
in this environment.

I suspect I'm just running into some little interaction, like I need to 
change this number here or this number doesn't match that number. If anyone 
can give me some pointers, I'd appreciate it. We've used PPCBOOT in the 
past on other architectures without any problem, so I'm surprised that this 
is giving me fits.


Jeff Tucker
jeff at jltnet.com

More information about the U-Boot mailing list