[U-Boot-Users] Re: Unable to send keys inputs from keyboard to u-boot

Wolfgang Denk wd at denx.de
Fri Jul 16 02:20:50 CEST 2004

In message <200407152259.i6FMxQ6o018397 at dbmail-mx4.orcon.co.nz> you wrote:
> I've tried 3 terminal program, 2 in windows (HyperTerminal & Tera Term
> Pro) and 1 in linux (minicom). Althought minicom is known to have 
> problems, it is only transmission of file across tftp that is
> problematic I think.

You are wrong. TFTP has nothing to do with  the  terminal  emulation.
It's the serial download which is broken in minicom.

> WD did suggest that it might just the flow control.
> I've tried all 3 settings available, Hardware, Xon/Xoff and None.
> All 3 of them have not worked.

"none" should be OK.

> I've been trying to see where the code stops and it seems to stop in
>    rcode = parse_stream(&temp, &ctx, inp, '\n');
> this is in common/hush.c line: 3154

This would mean that your input has actually been processed somewhat.

To make things easier try disabling hush.

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: wd at denx.de
The man on tops walks a lonely street;  the  "chain"  of  command  is
often a noose.

More information about the U-Boot mailing list