[U-Boot-Users] 4xx ethernet bringup

shami Allam shamiuboot at yahoo.co.in
Thu Dec 20 12:52:43 CET 2007

Hi Stefan,
  I assigned the ethaddr as and after that i run the command "saveenv " and reset the board. I got the following
Net: ppc_4xx_eth0. once i get the shell prompt i assign the ipaddr as and after that i run the command "saveenv" and reset the board. Now i tried to ping my Host PC which has the IP address as, i am getting the following error.....I am not able to ping the host IP. Can you please show some way to come of this issue.....
=> ping
Trying ppc_4xx_eth0
PHY speed read failed, assuming 10bT
PHY duplex read failed, assuming half duplex
ENET Speed is 10 Mbps - HALF duplex connection
Using ppc_4xx_eth0 device
sending ARP for c0a80df0
ARP broadcast 1
ARP broadcast 2
ping failed; host is not alive

Stefan Roese <sr at denx.de> wrote:
  On Wednesday 19 December 2007, shami Allam wrote:
> I am working on the 405GP custome board. I am able to bringup the
> SDRAM,Flash,I2c and serail on the board. But while trying to bringup the
> ethernet i am getting the following error. "No Ethernet found". On my board
> there is "DP83848I" PHY chip.

This message gets printed when you don't define the "ethaddr" environement 
address. So set this variable to a valid value and save the environment and 
reset the board. Then you should see one eth-interface.

Best regards,

DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: +49-8142-66989-0 Fax: +49-8142-66989-80 Email: office at denx.de

 Get the freedom to save as many mails as you wish. Click here to know how.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.denx.de/pipermail/u-boot/attachments/20071220/dc27ad89/attachment.htm 

More information about the U-Boot mailing list