[U-Boot-Users] Failed to run "hello world" 1.1.6 example on AT91RM9200EK

Wolfgang Denk wd at denx.de
Thu May 3 21:22:09 CEST 2007

In message <10308910.post at talk.nabble.com> you wrote:
> i ve tried to load it at 40000 and execute it at 40004 as said in the doc, i

...and that doc was for an ARM system, are you really sure about that?

> ve also tried to load it at 20000000 and start it at 20000000 and 20000004
> but nothing works. 

And why do you think 20000000 would be a better address for ARM?

> Any idea ? 

I see at least thre different options for you:

1) You just have a look at the messages that are printed when
   building and linking your SA application; the start address of the
   text segment is easily visible there.
2) You could try and look at the source code, for example in
3) You could (warning, terror starts here) read the documentation,
   especially a part nobody reads: the FAQ. See
   [Agreed, a headline of "My standalone program does not work" is
   really difficult to find if you are looking for problems why your
   standalone program does not work...]


Wolfgang Denk

DENX Software Engineering GmbH,    CEO: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
A quarrel is quickly settled when deserted by one party; there is  no
battle unless there be two.                                  - Seneca

More information about the U-Boot mailing list