[U-Boot] Question: Installing U-Boot on the Karo TX25

Züger Martin martin.zueger at ntb.ch
Thu Mar 22 09:08:00 CET 2012

Hi everybody

My name is Martin and I'm new to this mailing list. I hope this is the right place to ask my question.
I'd like to install U-Boot on a Karo TX25. From the Denx FTP server I've downloaded the 2011.12 release of U-Boot and compiled it using the arm-linux-gnueabi-gcc (4.4.5) from Debian:
  $ make tx25_config
  $ CROSS_COMPILE=arm-linux-gnueabi- make all
After compiling I've downloaded the u-boot.bin file to the board using the pre-installed RedBoot:
  RedBoot> load -r -b 0x80100000 -h u-boot.bin
  Using default protocol (TFTP)
  Raw file loaded 0x80100000-0x80129617, assumed entry at 0x80100000
Finally I tried to start U-Boot directly from RAM:
  RedBoot> exec
  Using base address 0x80100000 and length 0x00029618
After that, the board (or at least the serial connection) stops working. I also tried the same with the pre-compiled binaries from here: http://www.denx-cs.de/sites/all/files/tx25.zip but with the same result.

May someone can explain me, how to download U-Boot to the Karo TX25 using the already installed RedBoot and execute it directly? Is this even possible? My final target is to replace RedBoot with U-Boot, so I'd like to write U-Boot to flash in a second step. Does I've to use the u-boot-nand.bin file instead of u-boot.bin for this?


Best regards,
Martin Zueger

More information about the U-Boot mailing list