[U-Boot] [PATCH v4 0/3] net: helper functions
Michael Walle
michael at walle.cc
Fri May 11 23:22:23 CEST 2012
Am Freitag 11 Mai 2012, 23:14:25 schrieb Wolfgang Denk:
> Dear Michael Walle,
>
> In message <201205112254.13896.michael at walle.cc> you wrote:
> > What about the rand function? I guess that should be two
> > compile time options
> >
> > - CONFIG_RAND
> > - CONFIG_RANDOM_HWADDR
> >
> > Any better names?
>
> Please make this a single option, CONFIG_RANDOM_MACADDR. It appears
> nobody else ever needed a random number before, and we can still
> factor this out if another user pops up after another 12 years.
from net/net.c:
unsigned int random_port(void)
{
return 1024 + (get_timer(0) % 0x4000);
}
CONFIG_BOOTP_RANDOM_DELAY, in net/bootp.c
--
michael
More information about the U-Boot
mailing list