[U-Boot] [PATCH 4/7] sunxi: Add CONFIG_MACPWR option
thomas.langer at lantiq.com
thomas.langer at lantiq.com
Mon Jul 28 10:09:34 CEST 2014
Hello Hans,
Hans de Goede wrote on 2014-07-27:
> On some boards the phy needs to be powered up through a gpio, add
> support for this.
>
> @@ -129,6 +129,11 @@ int cpu_eth_init(bd_t *bis)
> {
> __maybe_unused int rc;
> +#ifdef CONFIG_MACPWR
If this is powering a phy, maybe CONFIG_PHYPWR or similar is a better name?
Because PHY and MAC are different things!
And maybe adding GPIO to the name to indicate that the value is a GPIO number?
All of these should be part of the description in the README,
which each CONFIG_ option requires.
> + gpio_direction_output(CONFIG_MACPWR, 1);
> + mdelay(200);
> +#endif
> +
> #ifdef CONFIG_SUNXI_EMAC
> rc = sunxi_emac_initialize(bis);
> if (rc < 0) {
Best Regards,
Thomas
---
There are two hard things in computer science: cache invalidation, naming things, and off-by-one errors.
---
More information about the U-Boot
mailing list