[U-Boot] [PATCH 1/2] fdt: Rename fdt_resize() to fdt_shrink_to_minimum()

Simon Glass sjg at chromium.org
Wed Jul 30 11:59:02 CEST 2014


Since libfdt now has an fdt_resize() function, we need to rename the
U-Boot one.

Signed-off-by: Simon Glass <sjg at chromium.org>
---

 common/cmd_fdt.c      | 2 +-
 common/fdt_support.c  | 2 +-
 common/image-fdt.c    | 2 +-
 include/fdt_support.h | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/common/cmd_fdt.c b/common/cmd_fdt.c
index e86d992..5640ded 100644
--- a/common/cmd_fdt.c
+++ b/common/cmd_fdt.c
@@ -621,7 +621,7 @@ static int do_fdt(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
 	}
 	/* resize the fdt */
 	else if (strncmp(argv[1], "re", 2) == 0) {
-		fdt_resize(working_fdt);
+		fdt_shrink_to_minimum(working_fdt);
 	}
 	else {
 		/* Unrecognized command */
diff --git a/common/fdt_support.c b/common/fdt_support.c
index 7927a83..784a570 100644
--- a/common/fdt_support.c
+++ b/common/fdt_support.c
@@ -508,7 +508,7 @@ void fdt_fixup_ethernet(void *fdt)
 }
 
 /* Resize the fdt to its actual size + a bit of padding */
-int fdt_resize(void *blob)
+int fdt_shrink_to_minimum(void *blob)
 {
 	int i;
 	uint64_t addr, size;
diff --git a/common/image-fdt.c b/common/image-fdt.c
index 9fc7481..0ea676b 100644
--- a/common/image-fdt.c
+++ b/common/image-fdt.c
@@ -476,7 +476,7 @@ int image_setup_libfdt(bootm_headers_t *images, void *blob,
 	lmb_free(lmb, (phys_addr_t)(u32)(uintptr_t)blob,
 		 (phys_size_t)fdt_totalsize(blob));
 
-	ret = fdt_resize(blob);
+	ret = fdt_shrink_to_minimum(blob);
 	if (ret < 0)
 		return ret;
 	of_size = ret;
diff --git a/include/fdt_support.h b/include/fdt_support.h
index fd44d7e..1bda686 100644
--- a/include/fdt_support.h
+++ b/include/fdt_support.h
@@ -76,7 +76,7 @@ void ft_cpu_setup(void *blob, bd_t *bd);
 void ft_pci_setup(void *blob, bd_t *bd);
 
 void set_working_fdt_addr(void *addr);
-int fdt_resize(void *blob);
+int fdt_shrink_to_minimum(void *blob);
 int fdt_increase_size(void *fdt, int add_len);
 
 int fdt_fixup_nor_flash_size(void *blob);
-- 
2.0.0.526.g5318336



More information about the U-Boot mailing list