[U-Boot] [PATCH] arm: socfpga: Add support for the Terasic DE-0 Atlas board
Marek Vasut
marex at denx.de
Tue Sep 1 17:37:38 CEST 2015
On Tuesday, September 01, 2015 at 05:09:09 PM, Dinh Nguyen wrote:
> On 08/31/2015 05:23 PM, Marek Vasut wrote:
> > On Monday, August 31, 2015 at 09:57:05 PM, dinguyen at opensource.altera.com
wrote:
> >> From: Dinh Nguyen <dinguyen at opensource.altera.com>
> >>
> >> Add support for the Terasic DE0-Nano/Atlas-SoC Kit, which is a CycloneV
> >> based board. The board can boot from SD/MMC. Ethernet is a bit different
> >> because it has a KSZ9031 PHY, so for now, ethernet doesn't quite work
> >> yet, as a few patches are needed to support the PHY.
> >
> > I thought we did support the KSZ9031 PHY. What's the problem ?
>
> Yeah, I just realized that. That's the problem when I've been working
> with v2013.10 U-Boot! I'll have ethernet in V2.
Cool :-)
> >> Signed-off-by: Dinh Nguyen <dinguyen at opensource.altera.com>
> >> ---
> >> Hi Marek,
> >>
> >> This patch is based on your u-boot-socfpga/wip/boards branch.
> >
> > OK, that makes sense.
> >
> >> Thanks,
> >> Dinh
> >> ---
> >>
> >> arch/arm/dts/Makefile | 1 +
> >> arch/arm/dts/socfpga_cyclone5_de0_sockit.dts | 61 +++
> >> arch/arm/mach-socfpga/Kconfig | 7 +
> >> board/terasic/de0/MAINTAINERS | 5 +
> >> board/terasic/de0/Makefile | 9 +
> >
> > I think it might be clearer to rename it to de0-nano-soc, what do you
> > think ? What's the difference between de0-nano-soc and atlas btw ?
>
> I don't know. From the website, DE0-Nano-SoC Kit/Atlas-SoC Kit, so
> DE0_Nano_SoCKit is synonymous with Atlas Sockit?
See the other email I guess.
> > [...]
> >
> >> diff --git a/configs/socfpga_de0_defconfig
> >> b/configs/socfpga_de0_defconfig new file mode 100644
> >> index 0000000..000f322
> >> --- /dev/null
> >> +++ b/configs/socfpga_de0_defconfig
> >> @@ -0,0 +1,21 @@
> >> +CONFIG_ARM=y
> >> +CONFIG_ARCH_SOCFPGA=y
> >> +CONFIG_TARGET_SOCFPGA_CYCLONE5=y
> >> +CONFIG_TARGET_SOCFPGA_TERASIC_DE0=y
> >> +CONFIG_DEFAULT_DEVICE_TREE="socfpga_cyclone5_de0_sockit"
> >> +CONFIG_SPL=y
> >> +# CONFIG_CMD_IMLS is not set
> >> +# CONFIG_CMD_FLASH is not set
> >> +CONFIG_OF_CONTROL=y
> >> +CONFIG_DM_ETH=y
> >> +CONFIG_NETDEVICES=y
> >> +CONFIG_ETH_DESIGNWARE=y
> >> +CONFIG_DM_GPIO=y
> >> +CONFIG_DWAPB_GPIO=y
> >> +CONFIG_SPL_DM=y
> >> +CONFIG_SPL_MMC_SUPPORT=y
> >> +CONFIG_DM_SEQ_ALIAS=y
> >
> > I think you don't need the DM_SEQ_ALIAS, it's needed only for QSPI
> > to enforce the SPI NOR ordering.
>
> Right, I missed this one.
:)
> <snip>
>
> >> +
> >> +/* USB */
> >> +#ifdef CONFIG_CMD_USB
> >> +#define CONFIG_USB_DWC2_REG_ADDR SOCFPGA_USB1_ADDRESS
> >> +#endif
> >> +#define CONFIG_G_DNL_MANUFACTURER "Terasic"
> >> +
> >> +/* Extra Environment */
> >> +#define CONFIG_HOSTNAME socfpga_cyclone5
> >
> > socfpga_d0_nano_soc might be better ;-)
>
> Yeah..missed this one too.
Thanks!
More information about the U-Boot
mailing list