[U-Boot] [uboot] [PATCH 6/7] net: phy: Add phy_interface_is_sgmii to phy.h
Michal Simek
michal.simek at xilinx.com
Mon Apr 11 09:06:52 CEST 2016
On 8.4.2016 18:08, Dan Murphy wrote:
> Add a helper to phy.h to identify whether the
> phy is configured for SGMII all variables.
>
> Signed-off-by: Dan Murphy <dmurphy at ti.com>
> ---
> include/phy.h | 11 +++++++++++
> 1 file changed, 11 insertions(+)
>
> diff --git a/include/phy.h b/include/phy.h
> index 7b2d1ff..ef3eb51 100644
> --- a/include/phy.h
> +++ b/include/phy.h
> @@ -288,6 +288,17 @@ static inline bool phy_interface_is_rgmii(struct phy_device *phydev)
> phydev->interface <= PHY_INTERFACE_MODE_RGMII_TXID;
> }
>
> +/**
> + * phy_interface_is_sgmii - Convenience function for testing if a PHY interface
> + * is SGMII (all variants)
> + * @phydev: the phy_device struct
> + */
> +static inline bool phy_interface_is_sgmii(struct phy_device *phydev)
> +{
> + return phydev->interface >= PHY_INTERFACE_MODE_SGMII &&
> + phydev->interface <= PHY_INTERFACE_MODE_QSGMII;
> +}
> +
> /* PHY UIDs for various PHYs that are referenced in external code */
> #define PHY_UID_CS4340 0x13e51002
> #define PHY_UID_TN2020 0x00a19410
>
Reviewed-by: Michal Simek <michal.simek at xilinx.com>
Thanks,
Michal
More information about the U-Boot
mailing list