[U-Boot] confused by "upgrade_available=0\0" in include/configs/taurus.h
Robert P. J. Day
rpjday at crashcourse.ca
Mon Jul 25 12:03:35 CEST 2016
On Mon, 25 Jul 2016, Wolfgang Denk wrote:
> Dear Robert,
>
> In message <alpine.LFD.2.20.1607230737010.12216 at localhost.localdomain> you wrote:
>
> > 3094 CONFIG_AT91SAM9XE
> > 3095 enable special bootcounter support on at91sam9xe based boards.
> > 3096 CONFIG_BLACKFIN
> > 3097 enable special bootcounter support on blackfin based boards.
> > 3098 CONFIG_SOC_DA8XX
> > 3099 enable special bootcounter support on da850 based boards.
>
> This is name space pollution t best, and has potential to cause
> unwanted side effects. This needs thorough checking and cleanup, if
> it should turn out thatthese macros are used only to select specific
> bootcount implementations - in that case, they should be renamed
> into something like CONFIG_BOOTCOUNT_* or such.
>
> Heiko, maybe you could have a look at that, please?
i'm not sure it's as bad as it looks, since those macros are used
specifically in drivers/bootcount/Makefile:
obj-y += bootcount.o
obj-$(CONFIG_AT91SAM9XE) += bootcount_at91.o
obj-$(CONFIG_BLACKFIN) += bootcount_blackfin.o
obj-$(CONFIG_SOC_DA8XX) += bootcount_davinci.o
obj-$(CONFIG_BOOTCOUNT_AM33XX) += bootcount_davinci.o
obj-$(CONFIG_BOOTCOUNT_RAM) += bootcount_ram.o
obj-$(CONFIG_BOOTCOUNT_ENV) += bootcount_env.o
obj-$(CONFIG_BOOTCOUNT_I2C) += bootcount_i2c.o
and drivers/bootcount/ is processed only if:
obj-$(CONFIG_BOOTCOUNT_LIMIT) += bootcount/
but i do see the single, more precise example of
CONFIG_BOOTCOUNT_AM33XX, so someone else can decide if anything
should be renamed here.
rday
--
========================================================================
Robert P. J. Day Ottawa, Ontario, CANADA
http://crashcourse.ca
Twitter: http://twitter.com/rpjday
LinkedIn: http://ca.linkedin.com/in/rpjday
========================================================================
More information about the U-Boot
mailing list