[U-Boot] [PATCH 1/3] ae3xx: timer: Rename AE3XX to ATCPIT100

rick at andestech.com rick at andestech.com
Tue Nov 21 07:27:18 UTC 2017



> -----Original Message-----
> From: U-Boot [mailto:u-boot-bounces at lists.denx.de] On Behalf Of
> rick at andestech.com
> Sent: Tuesday, November 21, 2017 2:40 PM
> To: sjg at chromium.org; Open Source Project uboot
> Cc: u-boot at lists.denx.de; dzu at denx.de
> Subject: Re: [U-Boot] [PATCH 1/3] ae3xx: timer: Rename AE3XX to ATCPIT100
>
>
> > -----Original Message-----
> > From: sjg at google.com [mailto:sjg at google.com] On Behalf Of Simon Glass
> > Sent: Monday, November 20, 2017 11:40 PM
> > To: Open Source Project uboot
> > Cc: U-Boot Mailing List; Wolfgang Denk; Detlev Zundel; Rick Jian-Zhi
> > Chen(陳建
> > 志)
> > Subject: Re: [PATCH 1/3] ae3xx: timer: Rename AE3XX to ATCPIT100
> >
> > Hi,
> >
> > On 14 November 2017 at 19:48, Andes <uboot at andestech.com> wrote:
> > > From: Rick Chen <rick at andestech.com>
> > >
> > > ATCPIT100 is Andestech timer IP which is embeded in AE3XX and AE250
> > > boards. So rename AE3XX to
> > > ATCPIT100 will be more make sence.
> > >
> > > Signed-off-by: Rick Chen <rick at andestech.com>
> > > ---
> > >  drivers/timer/Kconfig           |    7 ++-
> > >  drivers/timer/Makefile          |    2 +-
> > >  drivers/timer/ae3xx_timer.c     |  117 ---------------------------------------
> > >  drivers/timer/atcpit100_timer.c |  117
> > > +++++++++++++++++++++++++++++++++++++++
> >
> > If this is just a rename, why the big delta?
> >
>
> I want to rename ae3xx_timer.c to atcpit100_timer.c By the way I also rename
> function name and and struct name to let it more reasonable.
> But I do not modify the code itself.
>
> Do you mean I shall not modify the content of atcpit100_timer.c ?
> Or I can modify but I shall describe it more clear ?
>

Though the patch is not easy to see the differences.
I tig it and list the delta for you reviewing

rename from drivers/timer/ae3xx_timer.c
rename to drivers/timer/atcpit100_timer.c
index b710c28..d5146dd 100644
--- a/drivers/timer/ae3xx_timer.c
+++ b/drivers/timer/atcpit100_timer.c
@@ -67,51 +67,51 @@ struct atctmr_timer_regs {
        u32     int_mask;       /* 0x38 */
 };

-struct atftmr_timer_platdata {
+struct atcpit_timer_platdata {
        u32 *regs;
 };

-static int atftmr_timer_get_count(struct udevice *dev, u64 *count)
+static int atcpit_timer_get_count(struct udevice *dev, u64 *count)
 {
-       struct atftmr_timer_platdata *plat = dev->platdata;
+       struct atcpit_timer_platdata *plat = dev->platdata;
        u32 val;
        val = ~(REG32_TMR(CH_CNT(1))+0xffffffff);
        *count = timer_conv_64(val);
        return 0;
 }

-static int atctmr_timer_probe(struct udevice *dev)
+static int atcpit_timer_probe(struct udevice *dev)
 {
-       struct atftmr_timer_platdata *plat = dev->platdata;
+       struct atcpit_timer_platdata *plat = dev->platdata;
        REG32_TMR(CH_REL(1)) = 0xffffffff;
        REG32_TMR(CH_CTL(1)) = APB_CLK|TMR_32;
        REG32_TMR(CH_EN) |= CH_TMR_EN(1 , 0);
        return 0;
 }

-static int atctme_timer_ofdata_to_platdata(struct udevice *dev)
+static int atcpit_timer_ofdata_to_platdata(struct udevice *dev)
 {
-       struct atftmr_timer_platdata *plat = dev_get_platdata(dev);
+       struct atcpit_timer_platdata *plat = dev_get_platdata(dev);
        plat->regs = map_physmem(devfdt_get_addr(dev) , 0x100 , MAP_NOCACHE);
        return 0;
 }

-static const struct timer_ops ag101p_timer_ops = {
-       .get_count = atftmr_timer_get_count,
+static const struct timer_ops atcpit_timer_ops = {
+       .get_count = atcpit_timer_get_count,
 };

-static const struct udevice_id ag101p_timer_ids[] = {
+static const struct udevice_id atcpit_timer_ids[] = {
        { .compatible = "andestech,atcpit100" },
        {}
 };

-U_BOOT_DRIVER(altera_timer) = {
-       .name   = "ae3xx_timer",
+U_BOOT_DRIVER(atcpit100_timer) = {
+       .name   = "atcpit100_timer",
        .id     = UCLASS_TIMER,
-       .of_match = ag101p_timer_ids,
-       .ofdata_to_platdata = atctme_timer_ofdata_to_platdata,
-       .platdata_auto_alloc_size = sizeof(struct atftmr_timer_platdata),
-       .probe = atctmr_timer_probe,
-       .ops    = &ag101p_timer_ops,
+       .of_match = atcpit_timer_ids,
+       .ofdata_to_platdata = atcpit_timer_ofdata_to_platdata,
+       .platdata_auto_alloc_size = sizeof(struct atcpit_timer_platdata),
+       .probe = atcpit_timer_probe,
+       .ops    = &atcpit_timer_ops,




> > >  4 files changed, 122 insertions(+), 121 deletions(-)  delete mode
> > > 100644 drivers/timer/ae3xx_timer.c  create mode 100644
> > > drivers/timer/atcpit100_timer.c
> >
> > Regards,
> > Simon
> CONFIDENTIALITY NOTICE:
>
> This e-mail (and its attachments) may contain confidential and legally privileged
> information or information protected from disclosure. If you are not the intended
> recipient, you are hereby notified that any disclosure, copying, distribution, or
> use of the information contained herein is strictly prohibited. In this case, please
> immediately notify the sender by return e-mail, delete the message (and any
> accompanying documents) and destroy all printed hard copies. Thank you for
> your cooperation.
>
> Copyright ANDES TECHNOLOGY CORPORATION - All Rights Reserved.
> _______________________________________________
> U-Boot mailing list
> U-Boot at lists.denx.de
> https://lists.denx.de/listinfo/u-boot
CONFIDENTIALITY NOTICE:

This e-mail (and its attachments) may contain confidential and legally privileged information or information protected from disclosure. If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution, or use of the information contained herein is strictly prohibited. In this case, please immediately notify the sender by return e-mail, delete the message (and any accompanying documents) and destroy all printed hard copies. Thank you for your cooperation.

Copyright ANDES TECHNOLOGY CORPORATION - All Rights Reserved.


More information about the U-Boot mailing list