[U-Boot] boot.bin on SD Card for SAMA5D3 Xplained

Eugen.Hristev at microchip.com Eugen.Hristev at microchip.com
Wed Dec 5 14:36:35 UTC 2018

On 05.12.2018 02:15, Daniel Evans wrote:
> Trying to get uboot SPL boot.bin to run on an SD card for the sama5d3 xplained board.  All I get is RomBOOT and no other messages.  I have tried throwing in a couple test pins to toggle in board_early_init_f but still not getting any debug.  I can get at91bootstrap to produce a boot.bin that works on the sama5d3 xplained so I am assuming I don’t have a bad board.  My boot partition is FAT16.  To compile I just run the following on Debian Buster :
> make mrproper
> make sama5d3_xplained_mmc_defconfig
> make
> Cross Compiler is gcc-linaro-6.4.1-2018.05-x86_64_arm-linux-gnueabihf
> When finished compiling I just copy the boot.bin to my BOOT partition.
> Has to be something obvious that I am missing.  Any insight is appreciated…


Check the datasheet for sama5d3 SoC section 11.4.3. - Valid code 
detection (my datasheet is dated 2 Feb 2016 if it helps)

Basically the vector 6 needs to have hardcoded the binary size. Are you 
doing that ? Otherwise the RomBOOT code will consider your binary as faulty.

PS. make sure endianess is right, use a good hexeditor...

Hope this helps,

> Dan
> _______________________________________________
> U-Boot mailing list
> U-Boot at lists.denx.de
> https://lists.denx.de/listinfo/u-boot

More information about the U-Boot mailing list