Chainloading U-Boot from Fastboot on Tegra30

Simon Glass sjg at
Sat Jul 4 21:53:00 CEST 2020

Hi Peter,

On Fri, 3 Jul 2020 at 06:33, Peter Geis <pgwipeout at> wrote:
> Good Morning,
> I am attempting to expand on the work for chainloading U-Boot on the
> nyan-big in order to chainload U-Boot on the Ouya Tegra30 device from fastboot.
> I have so far been unsuccessful at getting any output from U-Boot
> through this method.
> I'm building the cardhu board with tweaks for Ouya's specifications
> similar to my work for the linux kernel.
> I build the image using mkbootimg --kernel u-boot.bin --ramdisk
> /dev/null --output u-boot-android.bin.
> I then fastboot boot u-boot-android.bin.
> I've tried tweaking the text base and tried both standard debug and
> low level debug.
> Do you think you could give me some insight into where I'm going wrong?

Is it possible that fastboot expects a relocatable image? If you set
up the debug UART very early you might be able to output a character
in start.S ?

BTW does U-Boot have support for the fastboot protocol? Perhaps you
could just use U-Boot?


More information about the U-Boot mailing list