[PATCH v2 01/14] drivers: rename drivers to match compatible string

Simon Glass sjg at chromium.org
Tue Jun 23 14:28:28 CEST 2020


On Fri, 19 Jun 2020 at 08:56, Walter Lozano <walter.lozano at collabora.com> wrote:
>
> When using OF_PLATDATA, the bind process between devices and drivers
> is performed trying to match compatible string with driver names.
> However driver names are not strictly defined, and also there are different
> names used when declaring a driver with U_BOOT_DRIVER, the name of the
> symbol used in the linker list and the used in the struct driver_info.
>
> In order to make things a bit more clear, rename the drivers names. This
> will also help for further OF_PLATDATA improvements, such as checking
> for valid driver names.
>
> Signed-off-by: Walter Lozano <walter.lozano at collabora.com>
> ---
>  .../mach-at91/arm926ejs/at91sam9260_devices.c |  6 +--
>  .../arm926ejs/at91sam9m10g45_devices.c        | 10 ++--
>  arch/arm/mach-rockchip/rk3328/syscon_rk3328.c |  4 +-
>  board/davinci/da8xxevm/omapl138_lcdk.c        |  2 +-
>  board/sandbox/sandbox.c                       |  2 +-
>  drivers/clk/at91/clk-master.c                 |  4 +-
>  drivers/clk/at91/clk-peripheral.c             |  4 +-
>  drivers/clk/at91/pmc.c                        |  4 +-
>  drivers/core/simple-bus.c                     |  4 +-
>  drivers/gpio/at91_gpio.c                      |  4 +-
>  drivers/gpio/da8xx_gpio.c                     |  4 +-
>  drivers/gpio/mxs_gpio.c                       |  6 +--
>  drivers/gpio/rk_gpio.c                        |  4 +-
>  drivers/gpio/sandbox.c                        |  4 +-
>  drivers/i2c/rk_i2c.c                          |  4 +-
>  drivers/input/cros_ec_keyb.c                  |  4 +-
>  drivers/misc/cros_ec_sandbox.c                |  4 +-
>  drivers/mmc/davinci_mmc.c                     |  4 +-
>  drivers/mmc/mxsmmc.c                          |  6 +--
>  drivers/mmc/rockchip_dw_mmc.c                 |  2 +-
>  drivers/mtd/spi/sf-uclass.c                   |  2 +-
>  drivers/mtd/spi/sf_probe.c                    |  4 +-
>  drivers/pinctrl/nxp/pinctrl-mxs.c             |  4 +-
>  drivers/pinctrl/pinctrl-at91.c                |  4 +-
>  drivers/pinctrl/rockchip/pinctrl-rk3188.c     |  2 +-
>  drivers/pinctrl/rockchip/pinctrl-rk3288.c     |  2 +-
>  drivers/pinctrl/rockchip/pinctrl-rk3328.c     |  2 +-
>  drivers/pinctrl/rockchip/pinctrl-rk3368.c     |  2 +-
>  drivers/power/pmic/rk8xx.c                    |  4 +-
>  drivers/power/regulator/fixed.c               |  4 +-
>  drivers/ram/rockchip/dmc-rk3368.c             |  2 +-
>  drivers/ram/rockchip/sdram_rk3188.c           |  2 +-
>  drivers/ram/rockchip/sdram_rk3288.c           |  2 +-
>  drivers/ram/rockchip/sdram_rk3328.c           |  2 +-
>  drivers/serial/sandbox.c                      |  6 +--
>  drivers/spi/mxs_spi.c                         |  6 +--
>  drivers/spi/rk_spi.c                          |  6 +--
>  drivers/spi/sandbox_spi.c                     |  4 +-
>  drivers/tpm/tpm_tis_sandbox.c                 |  4 +-
>  drivers/video/rockchip/rk3288_vop.c           |  4 +-
>  drivers/video/sandbox_sdl.c                   |  4 +-
>  drivers/watchdog/at91sam9_wdt.c               |  4 +-
>  test/dm/gpio.c                                |  2 +-
>  test/dm/spi.c                                 |  6 +--
>  test/py/tests/test_bind.py                    | 54 +++++++++----------
>  45 files changed, 104 insertions(+), 120 deletions(-)
>

Reviewed-by: Simon Glass <sjg at chromium.org>


More information about the U-Boot mailing list