[U-Boot] [PATCH v3 0/17] sandbox: Generic board support and other improvements
Simon Glass
sjg at chromium.org
Fri Apr 26 15:10:15 CEST 2013
Hi Tom,
On Mon, Apr 22, 2013 at 9:08 AM, Simon Glass <sjg at chromium.org> wrote:
> Hi Tom,
>
> On Mon, Apr 22, 2013 at 8:18 AM, Tom Rini <trini at ti.com> wrote:
>> On Sat, Apr 20, 2013 at 11:42:35AM -0700, Simon Glass wrote:
>>
>>> This series adds generic board support to sandbox and switches to use this
>>> always.
>>>
>>> With sandbox it was noticed that turning CONFIG_SYS_GENERIC_BOARD off
>>> can cause a build failure if a previous autoconf.mk exists which indicates
>>> that generic board is not supported, so a patch is provided to fix this.
>>>
>>> It is useful to convert a pointer into an 'address' in the sandbox RAM
>>> buffer - the opposite of map_sysmem(). This is added in this series and
>>> used in several places.
>>>
>>> With sandbox it is easier to read a file from the host than to use the
>>> CONFIG_OF_SEPARATE option, since this option requires knowledge of the
>>> executable image structure which is not really appropriate on the host
>>> system. A new CONFIG_OF_HOSTFILE provides this.
>>>
>>> A few related FDT changes are included in this series also.
>>>
>>> The -c option is enhanced to support passing entire scripts to sandbox.
>>> This is useful when writing non-trivial test code.
>>>
>>> Most of these patches were previously submitted as part of the verified
>>> boot effort. This series collects the independent sandbox-related patches
>>> together to make it easier to review. THe whole series is marked as
>>> version 3 for this reason.
>>
>> For the series,
>> Reviewed-by: Tom Rini <trini at ti.com>
>>
>> And I'd say 3/4/5 should be squashed into one patch, but it's your arch
>> so I'l defer if you think it adds bisect value or similar to do it in
>> that manner.
>
> I did that so that it could be kind-of an example of how this can be
> done for an arch, given that I am not planning to convert the rest. By
> removing the dead code in a separate step it seemed a bit clearer to
> me.
>
> But it's fine either way - I will squash it and resend.
I have put this series in patchwork as:
http://patchwork.ozlabs.org/bundle/sjg/sandbox/
and below is a pull request if you want to take that instead.
I did not go through and add your Reviewed-by to each patch. Am I
supposed to do that?
The following changes since commit d10f68ae47b67acab8b110b5c605dde4197a1820:
Prepare v2013.04 (2013-04-19 10:25:43 -0400)
are available in the git repository at:
git://git.denx.de/u-boot-x86.git sandbox
for you to fetch changes up to 3a95570c609a35f60d4c798948f83f8427544ff2:
sandbox: config: Enable CONFIG_FIT and CONFIG_CMD_FIT (2013-04-26
06:00:06 -0700)
----------------------------------------------------------------
Simon Glass (15):
Trigger generic board error only when building
sandbox: Provide a way to map from host RAM to U-Boot RAM
sandbox: Switch over to generic board
sandbox: Add CONFIG_OF_HOSTFILE to read FDT from host file
fdt: Add a parameter to fdt_valid()
Add getenv_hex() to return an environment variable as hex
fdt: Allow fdt command to check and update control FDT
sandbox: fdt: Support fdt command for sandbox
fdt: Skip checking FDT if the pointer is NULL
Revert "fdt- Tell the FDT library where the device tree is"
sandbox: Allow -c argument to provide a command list
sandbox: Support 'source' command
fs: Add support for saving data to filesystems
sandbox: fs: Add support for saving files to host filesystem
sandbox: config: Enable CONFIG_FIT and CONFIG_CMD_FIT
Makefile | 10 ++
arch/sandbox/config.mk | 5 +-
arch/sandbox/cpu/cpu.c | 5 +
arch/sandbox/cpu/start.c | 9 +-
arch/sandbox/include/asm/io.h | 8 ++
arch/sandbox/include/asm/state.h | 1 +
arch/sandbox/include/asm/u-boot.h | 22 +--
arch/sandbox/lib/Makefile | 1 -
arch/sandbox/lib/board.c | 285 --------------------------------------
board/sandbox/sandbox/sandbox.c | 2 +-
common/board_f.c | 106 ++++++++++++--
common/board_r.c | 8 +-
common/cmd_fdt.c | 87 ++++++++----
common/cmd_nvedit.c | 15 ++
common/cmd_sandbox.c | 18 ++-
common/cmd_source.c | 11 +-
common/main.c | 8 --
config.mk | 4 +-
doc/README.fdt-control | 6 +-
fs/fs.c | 75 ++++++++++
fs/sandbox/sandboxfs.c | 33 +++++
include/asm-generic/sections.h | 2 +-
include/common.h | 18 +++
include/configs/sandbox.h | 11 +-
include/fs.h | 2 +
include/sandboxfs.h | 1 +
lib/fdtdec.c | 5 +-
27 files changed, 383 insertions(+), 375 deletions(-)
delete mode 100644 arch/sandbox/lib/board.c
Regards,
Simon
More information about the U-Boot
mailing list